[RFE] Better UI for tab spacing

RESOLVED FIXED

Status

Other Applications
ChatZilla
--
enhancement
RESOLVED FIXED
17 years ago
12 years ago

People

(Reporter: xyzzy, Assigned: Gijs)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-patch][cz-0.9.69.2])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
I was informed that gaps in tabs in Chatzilla are an attempt to mimic function
key spacing on the keyboard.  This should be exposed in the UI so that it
doesn't look like a bug, and I would like the ability to turn this feature off.

Filing this bug for additional comments and proposals for this UI.

Comment 1

17 years ago
Since chatzilla can have multiple connections to servers, shouldn't these gaps
separate channels from differents servers?

Something like:

[Server1][#channel1][#channel2][#channel3] [Server2][#channel1][#channel4]

(or see the new mirc 6.0x who has this feature)
(Reporter)

Comment 2

17 years ago
See bug 110550 for an alternate proposal for multiple-server tabbing UI.
Product: Core → Other Applications
(Assignee)

Comment 3

13 years ago
*** Bug 288320 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Depends on: 76175
(Assignee)

Comment 4

13 years ago
To turn this feature off, use userChrome.css to remove the 5px left margin on
the 5th and 9th tab (see
http://lxr.mozilla.org/seamonkey/source/extensions/irc/xul/skin/chatzilla.css#113 )

That comment vs. the code is confusing, by the way, because the tabs with
viewKey 4 and 8 are actually the 5th and 9th tabs (that's why it's margin-left).
Ah well.
(Assignee)

Comment 5

13 years ago
Created attachment 202650 [details] [diff] [review]
Patch to add a pref to disable the keyboard-like tab spacing

Patch that adds an attribute selector to the css rule so we can modify whether or not it applies by using js in the app. Thanks to Mook for this excellent suggestion!

I can imagine people want more control, such as splitting by server and whatnot (as mentioned in the comments). However, there are other bugs for that. This patch is solely about making the tab spacing configurable - should the Powers That Be not want to do that, then I'd like this bug marked wontfix. More control about all this may be provided when we get a multiple windows interface.
Attachment #202650 - Flags: review?(samuel)

Updated

13 years ago
Attachment #202650 - Flags: review?(samuel) → review+

Comment 6

13 years ago
I find it handy to have the spacing even if the keyboard doesn't have the same spacing.  But this is good so that it can be turned off.
Whiteboard: cz-patch

Comment 7

13 years ago
Urg, not more prefs. Can we not just remove the spacing?
(Assignee)

Comment 8

13 years ago
Created attachment 206715 [details] [diff] [review]
Kill tab spacing

Fine by me.
Assignee: rginda → gijskruitbosch+bugs
Attachment #202650 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #206715 - Flags: review?(silver)

Updated

13 years ago
Attachment #206715 - Flags: review?(silver) → review+

Comment 9

13 years ago
Checked in --> FIXED.

I believe other issues about the tabs are covered by other bugs, and if not it would probably be best to file new ones.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Whiteboard: cz-patch → [cz-patch][cz-0.9.69.2]
You need to log in before you can comment on or make changes to this bug.