Closed Bug 1147424 Opened 5 years ago Closed 5 years ago

IonMonkey MIPS: Fix build failures on MIPS caused by recent updates (MacroAssemblerMIPS::ma_b).

Categories

(Core :: JavaScript Engine: JIT, defect)

Other
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox39 --- fixed

People

(Reporter: aleksandar.zlicic, Assigned: aleksandar.zlicic)

References

Details

Attachments

(1 file, 1 obsolete file)

/home/v8mips/work/Mozilla_simulator/mozilla-central/js/src/jit/mips/CodeGenerator-mips.h: In instantiation of ‘void js::jit::CodeGeneratorMIPS::bailoutCmp32(js::jit::Assembler::Condition, T1, T2, js::jit::LSnapshot*) [with T1 = js::jit::Register; T2 = js::jit::ImmWord]’:
/home/v8mips/work/Mozilla_simulator/mozilla-central/js/src/jit/mips/CodeGenerator-mips.h:87:9:   required from ‘void js::jit::CodeGeneratorMIPS::bailoutCmpPtr(js::jit::Assembler::Condition, T1, T2, js::jit::LSnapshot*) [with T1 = js::jit::Register; T2 = js::jit::ImmWord]’
/home/v8mips/work/Mozilla_simulator/mozilla-central/js/src/jit/mips/CodeGenerator-mips.cpp:1758:78:   required from here
/home/v8mips/work/Mozilla_simulator/mozilla-central/js/src/jit/mips/CodeGenerator-mips.h:66:9: error: no matching function for call to ‘js::jit::MacroAssembler::ma_b(js::jit::Register&, js::jit::ImmWord&, js::jit::Label*, js::jit::Assembler::Condition, js::jit::JumpKind)’
/home/v8mips/work/Mozilla_simulator/mozilla-central/js/src/jit/mips
Attached patch Bug_1147424.patch (obsolete) — Splinter Review
Attachment #8583118 - Flags: review?(branislav.rankov)
Comment on attachment 8583118 [details] [diff] [review]
Bug_1147424.patch

Review of attachment 8583118 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/jit/mips/MacroAssembler-mips.h
@@ +242,5 @@
> +    void ma_b(Address addr, ImmWord imm, Label *l, Condition c, JumpKind jumpKind = LongJump)
> +    {
> +        MOZ_ASSERT(rhs != ScratchRegister);
> +        ma_lw(ScratchRegister, addr);
> +        ma_b(ScratchRegister, imm, l, c, jumpKind);

You should call this function below:
void ma_b(Address addr, Imm32 imm, Label *l, Condition c, JumpKind jumpKind = LongJump);

Also, you can't use ScratchRegister when calling into ma_b. You should use SecondScratchReg.
Attachment #8583118 - Flags: review?(branislav.rankov) → review-
Thanks, I have totally overlooked that.
I have redone the patch.
Attachment #8583118 - Attachment is obsolete: true
Attachment #8583201 - Flags: review?(branislav.rankov)
Comment on attachment 8583201 [details] [diff] [review]
Bug_1147424.patch

Review of attachment 8583201 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8583201 - Flags: review?(branislav.rankov) → review+
Keywords: checkin-needed
Duplicate of this bug: 1147782
Assignee: nobody → aleksandar.zlicic
https://hg.mozilla.org/mozilla-central/rev/f93153e7329e
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.