File->Close vs. View-Close

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: horkana, Assigned: rginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

17 years ago
i wanted to close the first tab, (client) i did not want to Quit.  

if closing this particular tab kills all the other open windows then i should at
least be warned.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 112695 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
this is not actually a duplicate
i had several tabs open, except the currently selected tab was the client tab.  

reopening
mail me if i need to give a more detailed description
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 3

17 years ago
Agreed, this is not a dupe of 112695 at all.

File->Close does not close a tab, it exits chatzilla.  View->Close closes a tab.
 I imagine this is a bit confusing, we'll probably have to do something about it.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

17 years ago
Summary: Close not Quit → File->Close vs. View-Close

Comment 4

16 years ago
Created attachment 119008 [details] [diff] [review]
patch v1

Moved [View]-[Close View] to [File]-[Close View].

In chatzilla, "View" has two meanings. I think "Close View" should be
changed to "Close Tab".

Updated

16 years ago
Attachment #119008 - Flags: review?(rginda)

Comment 5

16 years ago
Created attachment 119126 [details] [diff] [review]
patch v2

The previous patch assigns the same shortcut key to "Close Tab"
and "Close Window".
Attachment #119008 - Attachment is obsolete: true

Updated

16 years ago
Attachment #119126 - Flags: review?(rginda)

Updated

16 years ago
Attachment #119008 - Flags: review?(rginda)

Comment 6

16 years ago
Tabs are views. File menu should have nothing to do with tab/view closing, only
window/CZ closing.

Comment 7

16 years ago
I'm not sure it's the best place for this comment..., but perhaps is it possible
to add a button "close this tab" just as it exists in the browser?

It may be be more functionnal than using the menu bar or the right click...
(Assignee)

Comment 8

16 years ago
marking fixed, 0.8.34 checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 9

15 years ago
Comment on attachment 119126 [details] [diff] [review]
patch v2

Request was obsolete.
Attachment #119126 - Flags: review?(rginda)
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.