All Bango purchases are failing with Movistar SIM

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: poc)

Tracking

Avenir
Points:
---

Details

(Reporter)

Description

3 years ago
SIMs tested with movistar (34 639 457 327), movistar (639311207), T-mobile (48698-525-199)


steps to reproduce:
1. Start an app purchase on marketplace stage with data roaming enabled + wifi.
2. Enter PIN
3. Confirm purchase


expected behavior:
Purchase is successful.

observed behavior:
Purchase is failing with 
03-25 10:36:41.638 E/GeckoConsole(  205): Content JS LOG at https://mozilla.bango.net/_/js/buynow-main.js:17 in anonymous: [object Object]  
03-25 10:36:41.638 E/GeckoConsole(  205): Content JS LOG at https://mozilla.bango.net/_/js/plugins/errors.js:5 in h: 1 3

From remote debugging:
Object { __type: "Bango.Common.UI.Payment.DoPaymentRe…", TransactionMethods: Array[0], TransactionId: 0, ResponseCode: "ERROR", ResponseMessage: "Error" } undefined undefined

reproducible? yes. both kumar and I have been hitting this error.
(Assignee)

Comment 1

3 years ago
Dear Krupa,

Thank you for raising this with us. Looking at the integration I can see that the two transactions for T-Mobile were decline due to the MSISDN not having enough credit to carry out the purchase.

Looking at the Movistar Spain transaction these all resulted in an ERROR. We will investigate these errors and update you as soon as possible.

Kind regards,

Jamie Seabrook
Bango Platform Operations Centre
(Assignee)

Comment 2

3 years ago
Dear Krupa,

I have raised the ERROR's you received with Movistar Spain and are currently awaiting their feedback.

Kind regards,

Jamie Seabrook
Bango Platform Operations Centre
(Assignee)

Comment 3

3 years ago
Dear Krupa,

Movistar Spain have advised us that the reason why these transactions have failed are due to their API rejecting the requests because there is an invalid symbol in the request. 

We are now investigating this internally to see if anything has been changed by ourselves or Movistar which would cause this issue.

Kind regards,

Jamie Seabrook
Bango Platform Operations Centre

Updated

3 years ago
Summary: All Bango purchases are failing → All Bango purchases are failing with Movistar SIM
(Assignee)

Comment 4

3 years ago
Dear Krupa,

We continue to investigate this issue with the assistance of the operator. We'll keep you updated on our progress.

Kind regards,

Max Pountney
Bango Platform Operations Center

Updated

3 years ago
Priority: -- → P1
(Assignee)

Comment 5

3 years ago
Dear Krupa, Andy,

As Telefonica Spain is no longer supported for carrier billing, you should no longer be able to reproduce this problem. See Bug Id 1149632.

Could you please confirm whether you require any further support from us on this?

Many thanks,

Max Pountney
Bango Platform Operations Center
Flags: needinfo?(krupa.mozbugs)
(Reporter)

Comment 6

3 years ago
I still get prompted to pay using my Movistar SIM using carrier billing. See screenshot: https://www.dropbox.com/s/tjm2ppsej63sm6m/Screenshot%202015-04-08%2010.51.03.png?dl=0

We should fix that for existing users, right?
Flags: needinfo?(krupa.mozbugs)
(Assignee)

Comment 7

3 years ago
Dear Krupa,

Please be advised that we are investigating why the DCB option is still available

In regards to the above however, as the service is being discontinued the issue will  no longer be able to be reproduced

Kind Regards

Tanya
Bango Platform Operations Center

Comment 8

3 years ago
Carrier billing is no longer active in Spain.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.