in-place updates result in multiple dock icons when Firefox was pinned to dock

RESOLVED DUPLICATE of bug 432520

Status

()

RESOLVED DUPLICATE of bug 432520
4 years ago
4 years ago

People

(Reporter: bmo, Unassigned)

Tracking

36 Branch
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
this has been happening for some time.  i just received an alert about the availability of the Fx 36.0.4 update.  i clicked through and told firefox to restart to update itself and somehow the OS gets confused and shows the new running copy of firefox on the dock as if it weren't a pinned app.  the old pinned icon also still is visible on the dock without the "currently running" dot indicator.  this doesn't seem to happen with Chrome or other self updates, so there must be something peculiar with the way firefox's update mechanism is doing things.

i'm using OSX 10.10.2
Component: Installer → Application Update
Product: Firefox → Toolkit
Stephen, I suspect this is a duplicate of the multiple dock icon bug. Could you look into this when you have the time?
Flags: needinfo?(spohl.mozilla.bugs)
I've been able to reproduce this as well, most recently this morning when my release copy of Firefox (36.0.4) updated to Firefox 37. FWIW, I've also seen Eclipse exhibit the same behavior. Closing the application and clicking on the pinned dock icon seems to fix the issue (until the next update).

(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #1)
> Stephen, I suspect this is a duplicate of the multiple dock icon bug.

I've been unable to find a bug regarding multiple dock icons. You wouldn't have the bug number handy, would you?
Flags: needinfo?(spohl.mozilla.bugs) → needinfo?(robert.strong.bugs)
I think it is similar or the same as bug 640669.

A couple of things to check:
Does this happen when exiting with an update ready and then starting Firefox?
Does this also happen when updating an add-on?
Flags: needinfo?(robert.strong.bugs)
(Reporter)

Comment 4

4 years ago
hi robert.

it's not clear to me who you're asking questions of.  me?  stephen?
Flags: needinfo?(robert.strong.bugs)
Stephen
Flags: needinfo?(robert.strong.bugs)
(Reporter)

Updated

4 years ago
Flags: needinfo?(spohl.mozilla.bugs)
Stephen, this is likely a duplicate of bug 640669 and the checks I asked you to perform in comment #3 will either point to it being a duplicate or not.

Comment 7

4 years ago
This is a duplicate of bug 640669 which is itself a duplicate of bug 432520.
Comment 7 is spot-on.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(spohl.mozilla.bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 432520
You need to log in before you can comment on or make changes to this bug.