<textarea> lowercases things that look like html closing tags

RESOLVED DUPLICATE of bug 64799

Status

()

Core
Layout: Form Controls
--
major
RESOLVED DUPLICATE of bug 64799
17 years ago
17 years ago

People

(Reporter: Craeg Strong, Assigned: rods (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I use <textarea> to edit XML files, and some of the tags look like HTML tags.
For example we might have:
<Section>
<Title>intro</Title>
<P>
  this is a test
</P>
<P>
  here's paragraph two
</P>
</Section>
As you will probably see from the above (this is being entered in a textarea)
The closing "P" tag and the closing "Title" tag are lowercased.  HOWEVER,
the opening tags are NOT lowercased.  Neither Opera nor Internet Explorer 6
exhibit this behavior.  According to spec, the content should be left alone.
Apparently, the textarea layout algorithm is being too clever and lowercasing
anything that it sees as an "html" closing tag.  Curious.
Um... The text you submitted does not have the tags lowercased...

Are you pre-filling the textarea with XML and not escaping the "<" and ">"
characters?
Duplicate of "Mozilla sometimes modifies the case of XML embedded in TEXTAREAS"

*** This bug has been marked as a duplicate of 64799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.