improve previews/screenshot scrolling

VERIFIED FIXED in 2015-04-07

Status

P3
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: kngo, Assigned: kngo)

Tracking

2015-04-07
x86
Mac OS X
Points:
---

Details

(Whiteboard: [qa+])

(Assignee)

Description

4 years ago
A big refactor.

STR:

1. Go to Popular page and App Detail page on both mobile and desktop.
2. Scroll back and forth.
3. Resize your browser window back and forth.

Expected:

You can scroll just enough to see all the previews.
The scroll bar beneath the preview tray is recalculated on resize.
No scroll bar when all previews are visible.

Actual:

Often, you can scroll past the last preview leaving a lot of grey space.
(Assignee)

Updated

4 years ago
Assignee: nobody → kngo
Priority: -- → P3
Whiteboard: [qa+]
Target Milestone: --- → 2015-03-31
(Assignee)

Comment 1

4 years ago
https://github.com/mozilla/fireplace/pull/1097
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

4 years ago
Also, I removed the lightbox/modal when on app detail page with viewport over 1050px.

Comment 3

4 years ago
After improving previews/screenshot scrolling I've noticed (in Popular, New, Recommended, Categories) that, for apps with only 3 screenshots, there are no next/prev arrows (I suppose this is intended) but user can move the screenshots and the arrows appear. Is this intended?
Please see screenshot: http://screencast.com/t/gasno3fe
Flags: needinfo?(kngo)

Comment 4

4 years ago
(In reply to ValentinaP from comment #3)
> After improving previews/screenshot scrolling I've noticed (in Popular, New,
> Recommended, Categories) that, for apps with only 3 screenshots, there are
> no next/prev arrows (I suppose this is intended) but user can move the
> screenshots and the arrows appear. Is this intended?
> Please see screenshot: http://screencast.com/t/gasno3fe

That looks unintentional.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

4 years ago
It's not intentional, but it's an improvement on prod now. I won't have time to focus on click/drag previews on desktop, can we verify it's an improvement/no regression and file a separate bug?
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(kngo)
Resolution: --- → FIXED

Comment 6

4 years ago
Valentina, please file a separate bug. Thanks!

Comment 7

4 years ago
The issue from comment #0 is still reproducing when user swipes between screenshots, in App Details Page and Popular, desktop and mobile, FF39.
Please see the screencast http://screencast.com/t/Sa6wYRj6L
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

4 years ago
Okay, you should only be able to touch-drag as far as there are previews now:

https://github.com/mozilla/fireplace/commit/c83b30547a2ad036989abda5e4ebb6720fab9e43
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Comment 9

4 years ago
Verified as fixed on FF39(Win 7) on MP-dev.
Postfix screencast: http://screencast.com/t/trfF2rWwCRH4
Closing bug.
Status: RESOLVED → VERIFIED

Comment 10

4 years ago
This was pushed to MP-prod, can we cherry-pick this fix, please?
Thanks!
(Assignee)

Comment 11

4 years ago
Krupa says this can wait until next week. Thanks for verifying.
(Assignee)

Updated

4 years ago
Target Milestone: 2015-03-31 → 2015-04-07
You need to log in before you can comment on or make changes to this bug.