Can't remove google.com cookie via Remove Cookie button

RESOLVED DUPLICATE of bug 1026538

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 1026538
3 years ago
3 years ago

People

(Reporter: Bartłomiej Brzozowiec (BartZilla), Unassigned)

Tracking

({privacy})

Trunk
privacy
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Bebelis/16.0.2
Build ID: 20121104132537

Steps to reproduce:

(Tested in the newest stable release, ie. 36.0.4, Linux and Windows)

0. Run the browser. When you run it first time, read the message:

"Welcome to Firefox
Committed to you, your privacy and an open Web."

[yeah, right...]

1. Open cookie manager:
   a. click on "Open menu" icon
   b. choose Preferences
   c. choose "Privacy" tab
   d. click on "remove individual cookies"
   e. in the "Search" field write "google.com"
   f. in the list of cookies choose cookie(s) from "google.com"; write down cookie content in external editor, it is sth like:
      ID=...:TM=...:LM=...:S=...
   g. click on "Remove Cookie" button; cookie(s) from "google.com" disappear(s)
   h. close cookie manager and Preferences window

2. Close the browser (optional step; doesn't change anything).

3. Open cookie manager and search again for cookies from "google.com" (refer to step 1 above).

4. You will notice that cookie from google.com still exists; it is the same cookie that you supposedly removed in step 1.g.


Actual results:

"Remove Cookie" button doesn't work in case of google.com cookie.


Expected results:

"Remove Cookie" button works in all cases.
(Reporter)

Updated

3 years ago
Component: Untriaged → Preferences
OS: Linux → All
Hardware: x86_64 → All
(Reporter)

Comment 1

3 years ago
Tested also in Nightly (same result; "Remove Cookie" button is named "Remove Selected"). From about:buildconfig:
"Built from https://hg.mozilla.org/mozilla-central/rev/5330c6f461a4"
(Reporter)

Updated

3 years ago
Version: 36 Branch → Trunk
(Reporter)

Updated

3 years ago
Keywords: privacy
(Reporter)

Comment 2

3 years ago
Additional info: persistent cookie is named "PREF".
(Reporter)

Comment 3

3 years ago
It seems that this persistent cookie is not sent during normal browsing (ie. when visiting google.com domain). I guess it is related with so-called "safebrowsing". Unfortunately, it is still impossible to remove it even when so-called "safebrowsing" is disabled.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1008706
(Reporter)

Comment 5

3 years ago
I was predicting exactly this problem 6 years ago, see https://bugzilla.mozilla.org/show_bug.cgi?id=368255#c32 footnote [1].
(Reporter)

Comment 6

3 years ago
Why bug 1008706? Why not bug 1026538?
Duplicate of bug: 1026538
You need to log in before you can comment on or make changes to this bug.