TypedArray regression from Bug 1139769 breaks JSZip

RESOLVED DUPLICATE of bug 1145058

Status

()

Core
JavaScript: Standard Library
RESOLVED DUPLICATE of bug 1145058
3 years ago
3 years ago

People

(Reporter: justindarc, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
The patch in attachment 8573096 [details] [diff] [review] that landed as part of Bug 1139769 has broken JSZip ( http://stuk.github.io/jszip/ ).

This was discovered in https://github.com/fxos/addon-generator while developing the Gaia Customizer add-on. When attachment 8573096 [details] [diff] [review] landed, the aforementioned addon-generator stopped producing valid zip files.

A somewhat reduced test case that illustrates the problem can be found here: http://jsbin.com/hogaze

If you run the above test case on latest mozilla-central, the ZIP file produced by clicking the "Download Add-on" link is corrupt. However, if you run the above test case on aurora/developer edition, B2G v2.2, or mozilla-central prior to the landing of attachment 8573096 [details] [diff] [review], the generated ZIP file is valid.

No errors are reported in the console and the JSZip library appears to continue functioning as intended, although the content it generates is corrupt.
(Reporter)

Updated

3 years ago
Blocks: 1133943
See Also: → bug 1139769
Blocks: 1139769
Flags: needinfo?(jwalden+bmo)
See Also: bug 1139769
(Reporter)

Comment 1

3 years ago
I spoke to Waldo and this is possibly a dupe of Bug 1145058. Let's re-test when it lands on nightly.
Flags: needinfo?(jwalden+bmo)
(Reporter)

Updated

3 years ago
Depends on: 1145058
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145058
You need to log in before you can comment on or make changes to this bug.