Closed Bug 1147650 Opened 8 years ago Closed 8 years ago

[Contacts] Quick scrolling via alphabet picker doesn't work properly

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
2.2 S9 (3apr)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: pcheng, Assigned: kats)

References

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files)

Attached file logcat of issue
Description:
Alphabet picker scrolling doesn't work correctly. The touch detection area seems to have shifted a little bit to the left, which makes it unintuitive because it's not directly over the alphabet picker.

STR:
0) Have some contacts in the app
1) Open Contacts
2) Attempt to use the alphabet picker on the right of the screen by sliding finger over the small gray letters

Expected: Quick scrolling works

Actual: Quick scrolling doesn't work over where it should work. If I slide a little bit to the left it works.

See video of issue:
https://www.youtube.com/watch?v=SpRGlDdVrYY

Also attaching a logcat.

Device: Flame 3.0 Master (full flash 319MB KK)
BuildID: 20150325010206
Gaia: aebfbd998041e960cea0468533c0b5041b504850
Gecko: cc0950b7a369
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
This issue doesn't occur on Flame 2.2. Scrolling via alphabet picker works over the expected area.

Device: Flame 2.2
BuildID: 20150325002503
Gaia: aeee2a54caa8ffb875b96264b61d742b70689f22
Gecko: 556aca3e50ac
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing]
[Blocking Requested - why for this release]:

Nominating this 3.0? since this is a regression from 2.2 and broken functionality.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Contact: ychung
I have the feeling this has been introduced by bug 1112551. It has landed in 2.2 yesterday. Pi Wei, can you check today's 2.2 to see if this issue has appeared?
Flags: needinfo?(pcheng)
Clearing the regression window flag until we have the confirmation bug 1112551 is or is not the cause. Please add it again once it's not related to bug 1112551.
This bug doesn't repro on today's 2.2. Seems like bug 1112551 isn't the cause here. Adding window-wanted tag back.

Device: Flame 2.2 (full flash 319MB KK)
BuildID: 20150326002504
Gaia: e59ac067a1d22b7a72cbebc892ec652723f2a557
Gecko: 04b4b9d1faae
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(pcheng)
Bug 1143518 seems to have caused this issue.

Mozilla-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150316091433
Gaia: 4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gecko: 6a42e09d9a26
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150316093332
Gaia: 4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gecko: 3d8fb4f958b5
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: 4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gecko: 3d8fb4f958b5

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 4868c56c0a3b7a1e51d55b24457e44a7709ea1ae
Gecko: 6a42e09d9a26

Gecko Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6a42e09d9a26&tochange=3d8fb4f958b5
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Kartikaya, can you take a look at this please? Looks like this was caused by the landing for bug 1143518.
Blocks: 1143518
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(bugmail.mozilla)
triage: major regression
blocking-b2g: 3.0? → 3.0+
The touch forwarder is eating the events. Prior to bug 1143518 we were bypassing the touch forwarder because of the event capture code path (which was technically wrong because listeners should receive all the events they're listening for). With that gone this bug got exposed. Patch coming once github decides to wake up and accept my push.
Assignee: nobody → bugmail.mozilla
Component: Gaia::Contacts → Gaia::System
Flags: needinfo?(bugmail.mozilla)
Attachment #8584535 - Flags: review?(etienne)
Comment on attachment 8584535 [details] [review]
[gaia] staktrace:forwarder > mozilla-b2g:master

cool :)
Attachment #8584535 - Flags: review?(etienne) → review+
Autolander, y u no land?
Flags: needinfo?(kgrandon)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Flags: needinfo?(kgrandon)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #12)
> Autolander, y u no land?

Sorry, it can be a bit slow to update. I'm looking at ways to improve the usability. It's easy enough to comment in the bug, but I'm not sure if that would cause too much churn.
I would have been happy with a comment when it removed the checkin-needed keyword.
Target Milestone: --- → 2.2 S9 (3apr)
This issue is verified fixed on the latest Nightly Flame 3.0 build.

Actual Results: The user can scroll along the Alphabet picker as expected.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150506010204
Gaia: 3e6fd1e0a478af2c95d09ce95c2c6de2de2fec14
Gecko: ba44099cbd07
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.