Closed Bug 1147651 Opened 5 years ago Closed 8 months ago

Allow username and password pairs to be stored differently for all parts of an URL

Categories

(Toolkit :: Password Manager, defect)

36 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 263387

People

(Reporter: krichter722, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150321180105

Steps to reproduce:

I saved a username/password pair for a service running under `example.org/service1` and want to save another pair of a completely different account for a service running under `example.org/service2` using the same username.


Actual results:

Firefox doesn't allow to add such an entry because it doesn't allow distinction of storage by the path components of URLs. One has to decide which is the most important password and skip saving the others.


Expected results:

Due to the fact that both offering the same username/password pairs for all pathes of a host and offering different account for different pathes of the the host make sense - depending on whether different services run under the host or not - the storage should be configurable. It should be sufficient to let the user decide during storage of passwords whether the associated URL should contain the path or not.
QA Whiteboard: [DUPEME]
Component: Untriaged → Password Manager
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263387
You need to log in before you can comment on or make changes to this bug.