Closed Bug 1147716 Opened 5 years ago Closed 5 years ago

browser_mcb_redirect.js is going to permafail when Gecko 39 merges to Aurora

Categories

(Core :: ImageLib, defect, blocker)

defect
Not set
blocker

Tracking

()

VERIFIED FIXED
mozilla39
Tracking Status
firefox39 + verified

People

(Reporter: RyanVM, Assigned: tanvi)

References

Details

Attachments

(1 file)

[Tracking Requested - why for this release]: Test permafail on Monday's uplift to Aurora.

https://treeherder.mozilla.org/logviewer.html#?job_id=5924725&repo=try

23:03:41 INFO - 501 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_mcb_redirect.js | uncaught exception - ReferenceError: ok is not defined at chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug435325.js:60
23:03:41 INFO - Stack trace:
23:03:41 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:simpletestOnerror:1476
23:03:41 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_mcb_redirect.js:test5:186
23:03:41 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_mcb_redirect.js:waitForCondition/moveOn:96
23:03:41 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_mcb_redirect.js:waitForCondition/interval<:91
23:03:41 INFO - null:null:0
23:03:41 INFO - JavaScript error: chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug435325.js, line 60: ReferenceError: ok is not defined
23:03:41 INFO - 502 INFO Console message: [JavaScript Error: "ReferenceError: ok is not defined" {file: "chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug435325.js" line: 60}] 

etc
Flags: needinfo?(tanvi)
Tracking for 39. Tanvi if you take this can you assign yourself to the bug? Thanks.
Investigating.
Assignee: nobody → tanvi
Flags: needinfo?(tanvi)
This is odd.

The tests written in browser_mcb_redirect.js actually complete successfully.

But we are getting an TEST-UNEXPECTED-FAIL because of a test that was run previously - browser_bug435325.js.  Looking at the logs and browser.ini, the other test runs quite a bit before browser_mcb_redirect.js[1].  The only thing in common between the two is that they are the only tests in browser/base/content/test/general that go into offline mode.

Looking at browser_bug435325.js, I don't see anything wrong with it's use of ok() here, as the error[2] suggests - https://mxr.mozilla.org/mozilla-central/source/browser/base/content/test/general/browser_bug435325.js#60

I've applied a patch from Ryan to make my local build Aurora.  Running browser_mcb_redirect.js shows no failures.  Now I'm running all of browser/base/content/test/general to see if that helps reproduce this failure.

Cc'ing Jim Mathias because he made the changes at browser_bug435325.js:60.  Jim, do you have any insight as to what is going on here?


[1] https://mxr.mozilla.org/mozilla-central/source/browser/base/content/test/general/browser.ini#176
and https://mxr.mozilla.org/mozilla-central/source/browser/base/content/test/general/browser.ini#492

[2] TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_mcb_redirect.js | uncaught exception - ReferenceError: ok is not defined at chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug435325.js:60
Crap, totally my fault with that test edit - we need to remove that observer when we get the callback, it's still active:

Services.obs.removeObserver(observer, "network:offline-status-changed", false);

should fix it.
Attachment #8583973 - Flags: review?(jmathies)
I've confirmed that with the patch the two tests run consecutively pass.  And without the patch we get the failures in the original logs.
Attachment #8583973 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/a489d18b4df2
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.