Closed Bug 114772 Opened 23 years ago Closed 22 years ago

Modal print dialog obscured by popup

Categories

(SeaMonkey :: UI Design, defect)

x86
Linux
defect
Not set
minor

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 65521

People

(Reporter: chennes, Assigned: bryner)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012
BuildID:    2001101202

A page loaded - I wanted to print it, so I chose print. A popup window with an
advertisement came up after I had selected print (apparently the page wan't done
loading after all). The popup dialog was displayed in front of the print dialog,
but could not be dismissed, since the print dialog had control. Similar to bug
65521?

Reproducible: Sometimes
Steps to Reproduce:
1.Go to a site that has popups
2.Before the page has loaded the popup, tell Mozilla to print


Actual Results:  When the popup is drawn, it is in front of the print window,
but can't grab focus.

Expected Results:  The modal dialog should ALWAYS be on top of any other Mozilla
window.
-> default assignee
Assignee: pchen → trudelle
Status: UNCONFIRMED → NEW
->bryner
Assignee: trudelle → bryner
Status: NEW → UNCONFIRMED
yeah. this should be fixed by bug 65521.
if i'm right. only the window from which print was print would be modal. 
you would still be able to interact with the popup (including closing it)

i could be wrong ...


*** This bug has been marked as a duplicate of 65521 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.