The default bug view has changed. See this FAQ.

Attempts to create a KEYED_MUTEX texture on a WARP device fail on windows 7

RESOLVED FIXED in Firefox 38

Status

()

Core
Graphics: Layers
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: bas, Assigned: bas)

Tracking

(Blocks: 1 bug)

unspecified
mozilla39
x86_64
Windows 8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm6+, firefox37+ wontfix, firefox38+ fixed, firefox39+ fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Currently we always try to create our synchronization texture. We shouldn't to this on D3D11 WARP on Windows 7 because this will fail and put our D3D11 WARP device in an invalid state.
(Assignee)

Comment 1

2 years ago
Created attachment 8583574 [details] [diff] [review]
Do not attempt to create a sync texture when using WARP

When using WARP D2D is disabled by default anyway. Since creating the sync texture will fail on Windows 7. For now let's not create one anywhere since this patch will need uplifting.
Attachment #8583574 - Flags: review?(jmuizelaar)
Attachment #8583574 - Flags: review?(jmuizelaar) → review+
Duplicate of this bug: 1128062
Duplicate of this bug: 1135247
Duplicate of this bug: 1127127
Duplicate of this bug: 1130788
Blocks: 1111396

Comment 6

2 years ago
Bug 1130788 was an e10s m6, updating this bug to reflect this.
tracking-e10s: --- → m6+
(Assignee)

Comment 7

2 years ago
[Tracking Requested - why for this release]: This is a really bad bug. And it exists in 37 as well. It's hard to say for how much trouble this is responsible on 37, but it affects all Win7 users that are blacklisted for D3D11 as far as I can tell :(.
tracking-firefox37: --- → ?
tracking-firefox38: --- → ?
Flags: needinfo?(milan)
I don't have the numbers, but we do get bugs with blacklisted Windows 7, and WARP and we do get the undocumented "out of memory" errors which suggest we're hitting this bug in other places, so we really do want to get this uplifted as high as it can go.  If we don't have time for 37, can we line it up for 37.0.1 if that happens?
Flags: needinfo?(milan) → needinfo?(lmandel)
Tracking this across the board.

We're too late for 37 if we still want to release on time. Please let me know if you think this is bad enough to warrant holding the release.

I have tracked this bug for 37 so that it will be on the list for consideration for a point release if one is necessary. In that case we will need to evaluate the risk that the fix causes other breakage against the impact of this bug on the user population in 37.
status-firefox37: --- → affected
status-firefox38: --- → affected
status-firefox39: --- → affected
tracking-firefox37: ? → +
tracking-firefox38: ? → +
tracking-firefox39: --- → +
Flags: needinfo?(lmandel)
I think we need a few days with the fix on the other channels, so I'd say this needs to wait for the dot release if it happens.
(Assignee)

Comment 11

2 years ago
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #9)
> Tracking this across the board.
> 
> We're too late for 37 if we still want to release on time. Please let me
> know if you think this is bad enough to warrant holding the release.
> 
> I have tracked this bug for 37 so that it will be on the list for
> consideration for a point release if one is necessary. In that case we will
> need to evaluate the risk that the fix causes other breakage against the
> impact of this bug on the user population in 37.

It's complicated.. if apparently we're happy with the quality of 37. Let's just ship it. It is a bad bug for the 37 population, but the beta population has already been living with this bug.
This hasn't landed anywhere yet, right?
https://hg.mozilla.org/mozilla-central/rev/96c8ca415e45
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox39: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Bas, is this something we should release note?
Flags: needinfo?(bas)
Comment on attachment 8583574 [details] [diff] [review]
Do not attempt to create a sync texture when using WARP

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]: Blocked configurations of Windows 7 (either blocklisted or vmware, remote desktop, etc.) will freeze.
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: 
[String/UUID change made/needed]:

Just to be clear - "aurora" refers to 38, "beta" to 37.  We know it won't be 37, but as it's tracked, readying in case there is a 37.0.1.
Attachment #8583574 - Flags: approval-mozilla-beta?
Attachment #8583574 - Flags: approval-mozilla-aurora?
Comment on attachment 8583574 [details] [diff] [review]
Do not attempt to create a sync texture when using WARP

As the merge is ongoing, I am doing to take it for beta (38) and marking "?" for release (37).
Attachment #8583574 - Flags: approval-mozilla-release?
Attachment #8583574 - Flags: approval-mozilla-beta?
Attachment #8583574 - Flags: approval-mozilla-beta+
Attachment #8583574 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/releases/mozilla-beta/rev/0a67b8adbc52
status-firefox38: affected → fixed
(Assignee)

Comment 18

2 years ago
(In reply to Milan Sreckovic [:milan] from comment #14)
> Bas, is this something we should release note?

In theory it shouldn't cause 'user-facing' issues. So I'm not sure there's something sensible we could put in a release note. The idea of this causing additional instability for affected users is purely theoretical and we don't know what exactly the symptoms of that would be.
Flags: needinfo?(bas)

Updated

2 years ago
Depends on: 1150376

Updated

2 years ago
Blocks: 993639

Updated

2 years ago
No longer blocks: 1111396
Duplicate of this bug: 1149958
This fix is too risky to take in release. I'm marking 37 as wontfix. We'll target 38.
status-firefox37: affected → wontfix
(Assignee)

Comment 21

2 years ago
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #20)
> This fix is too risky to take in release. I'm marking 37 as wontfix. We'll
> target 38.

Very good decision, this fix causes bug 1150376!
Comment on attachment 8583574 [details] [diff] [review]
Do not attempt to create a sync texture when using WARP

Missed marking this as release- earlier.
Attachment #8583574 - Flags: approval-mozilla-release? → approval-mozilla-release-

Updated

2 years ago
Depends on: 1165732
You need to log in before you can comment on or make changes to this bug.