IonMonkey: MIPS: Fix build failure caused by recent changes (visitGuardReceiverPolymorphic)

RESOLVED DUPLICATE of bug 1147424

Status

()

Core
JavaScript Engine: JIT
RESOLVED DUPLICATE of bug 1147424
3 years ago
3 years ago

People

(Reporter: hev, Unassigned)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
In file included from /home/heiher/git/loongson/gecko-dev/js/src/jit/CodeGenerator.h:22:0,
                 from /home/heiher/git/loongson/gecko-dev/js/src/jit/CodeGenerator.cpp:7,
                 from /home/heiher/git/loongson/gecko-dev/js/src/mips/js/src/Unified_cpp_js_src3.cpp:110:
/home/heiher/git/loongson/gecko-dev/js/src/jit/mips/CodeGenerator-mips.h: In instantiation of ‘void js::jit::CodeGeneratorMIPS::bailoutC
mp32(js::jit::Assembler::Condition, T1, T2, js::jit::LSnapshot*) [with T1 = js::jit::Address; T2 = js::jit::ImmWord]’:
/home/heiher/git/loongson/gecko-dev/js/src/jit/mips/CodeGenerator-mips.h:87:9:   required from ‘void js::jit::CodeGeneratorMIPS::bailout
CmpPtr(js::jit::Assembler::Condition, T1, T2, js::jit::LSnapshot*) [with T1 = js::jit::Address; T2 = js::jit::ImmWord]’
/home/heiher/git/loongson/gecko-dev/js/src/jit/CodeGenerator.cpp:2569:50:   required from here
/home/heiher/git/loongson/gecko-dev/js/src/jit/mips/CodeGenerator-mips.h:66:9: error: no matching function for call to ‘js::jit::MacroAs
sembler::ma_b(js::jit::Address&, js::jit::ImmWord&, js::jit::Label*, js::jit::Assembler::Condition, js::jit::JumpKind)’
         masm.ma_b(lhs, rhs, &skip, Assembler::InvertCondition(c), ShortJump);
(Reporter)

Comment 1

3 years ago
Created attachment 8583702 [details] [diff] [review]
IonMonkey-MIPS-Fix-Fix-build-failure-caused-by-recen.patch
Attachment #8583702 - Flags: review?(branislav.rankov)
Comment on attachment 8583702 [details] [diff] [review]
IonMonkey-MIPS-Fix-Fix-build-failure-caused-by-recen.patch

Review of attachment 8583702 [details] [diff] [review]:
-----------------------------------------------------------------

I have already reviewed a patch for this bug from Aleksandar Zlicic in bug 1147424
Attachment #8583702 - Flags: review?(branislav.rankov) → review-
Aleksandar, Heiher, 

Can you please synchronize next time with issues like this so that we can avoid duplicating work.

Just add the bug once you start working on it, CC interested parties and assign it to yourself.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1147424
You need to log in before you can comment on or make changes to this bug.