If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

File menu: "Ctrl+W" says just "Close Tab", but when there is one tab, it actually also closes the window by default.

RESOLVED DUPLICATE of bug 514053

Status

()

Firefox
Menus
--
minor
RESOLVED DUPLICATE of bug 514053
3 years ago
3 years ago

People

(Reporter: Magnus Johansson, Unassigned)

Tracking

({ux-discovery, ux-error-prevention})

36 Branch
x86
Windows XP
ux-discovery, ux-error-prevention
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150320202338

Steps to reproduce:

In the File menu the item "Close tab   Ctrl+W" should say "Close tab or window    Ctrl+W" since Ctrl+W closes a tab when there are two tabs or more in the window, but closes the window when there is only one tab.

Comment 1

3 years ago
It would be more true, but I think it's not worth it.
1. It is confusing when multiple tabs are open, and changing the text when there is only one tab would require additional code (although there was an option to hide the tab bar in that case, it seems to not exist any more).
2. If you enter about:config in the address bar, you can use a pref called browser.tabs.closeWindowWithLastTab to toggle whether closing the only tab closes the window, so the code would need to consider that pref.
Component: Untriaged → Menus

Updated

3 years ago
Severity: normal → minor
Keywords: ux-discovery, ux-error-prevention
Summary: Missing information in File menu → File menu: "Ctrl+W" says just "Close Tab", but when there is one tab, it actually also closes the window by default.
(Reporter)

Comment 2

3 years ago
(In reply to [:Aleksej] from comment #1)
> It would be more true, but I think it's not worth it.
> 1. It is confusing when multiple tabs are open, and changing the text when
> there is only one tab would require additional code (although there was an
> option to hide the tab bar in that case, it seems to not exist any more).
> 2. If you enter about:config in the address bar, you can use a pref called
> browser.tabs.closeWindowWithLastTab to toggle whether closing the only tab
> closes the window, so the code would need to consider that pref.

OK. Thanks, Aleksej. I have now changed the pref so that Firefox behaves more in accordance with its File menu.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 514053
You need to log in before you can comment on or make changes to this bug.