Update infrastructure to something with python 2.7

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: Pike, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
We need python 2.7 to get on to django versions that get security updates, see bug 1147814.

I guess there's two ways:

Get some self-compiled or tacky version of 2.7 onto the bm-l10n-dashboard01 VM.

Spin up new VMs with 2.7, and proper OPS support like puppet etc.
- dev first
- prod second
- buildbot pieces last

If we go for the latter, we'll also need a build log retention setup. I looked at the built-in buildbot code for that, and that's ughly, so a django management command sounds more like it.
(Reporter)

Updated

4 years ago
Depends on: 1152747
(Reporter)

Updated

3 years ago
Depends on: 1156760
(Reporter)

Comment 1

2 years ago
This is FIXED now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.