If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Disable filing of bookmarks to IE Favorites folder

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
P3
normal
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Chris Lyon, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({dataloss})

Trunk
mozilla1.2alpha
x86
Windows XP
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using build 2001121103 on WinXP

Steps to Reproduce:
1- File Bookmark
2- Select IE Favorites folder
3- Click OK

Expected Results:
Since we can't write to the IE Favorites folder, the OK button should be 
disabled or an alert should pop up

Actual Results:
The bookmark gets filed below the IE Favorites folder, in the root bookmarks 
folder.
(Reporter)

Comment 1

16 years ago
If you try to delete the new bookmark, the following JS errors appear int he 
JS console:

Error: [Exception... "Component returned failure code: 0x80070057 
(NS_ERROR_ILLEGAL_VALUE) [nsIOutlinerView.isContainer]"  nsresult: "0x80070057 
(NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: <unknown filename> :: 
BMOLController_isCommandEnabled :: line 48"  data: no]
Source File: 
Line: 48


Error: uncaught exception: [Exception... "Component returned failure code: 
0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIOutlinerView.isContainer]"  
nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: 
<unknown filename> :: BMOLController_isCommandEnabled :: line 48"  data: no]
(Reporter)

Comment 2

16 years ago
Sorry, those JS errors occur when deleting any bookmark, not just that one.

Comment 3

16 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Updated

16 years ago
Blocks: 120814

Comment 4

16 years ago
I added the dataloss keyword, and the Mozilla 1.0 keyword, to nominate this for
Mozilla 1.0.

This is a dataloss bug. The amount of data is pretty small, I admit, but it's
still a loss of data.

The user expects that the bookmark will be saved in "Imported IE Favorites." It
isn't. If Granny doesn't check soon, she will never realize that a site she
wanted to bookmark, was not bookmarked.

There are different ways to solve this problem. One way would be to remove
"Imported IE Favorites" from the list of Bookmark Folders in the "File Bookmark"
dialog box. The advantage is that it is clean. 

Alternatively, an error message would also solve this bug. It would be
frustrating to the user, however. A user could ask, why display "Imported IE
Favorites" in "File Bookmark" when I can't file a bookmark there?
Keywords: dataloss, mozilla1.0
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.2
(Reporter)

Comment 5

16 years ago
This now works due to the fix for bug 106326.

Comment 6

16 years ago
It looks like it's fixed to me, too.

I don't know if this bug has a rationale any more. Maybe it should be resolved 
as fixed or as a duplicate of bug 106326.

Comment 7

16 years ago
Resolving as worksforme on basis of comments.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
No longer blocks: 120814
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.