[e10s] Flashblock add-on always active

RESOLVED FIXED

Status

()

Firefox
Extension Compatibility
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Jonathan Howard, Assigned: mao)

Tracking

({addon-compat})

Trunk
addon-compat
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Flash remains blocked when using the tool button to disable its blocking or for anything added to the white list.
(Reporter)

Updated

3 years ago
tracking-e10s: --- → ?
Keywords: addon-compat
Blocks: 905436
tracking-e10s: ? → +

Updated

3 years ago
Flags: needinfo?(twalker)
Whiteboard: dupme

Comment 1

3 years ago
Created attachment 8585536 [details]
flashblock-1.5.19a1.xpi

This is the latest version of Flashblock (there are no e10s specific changes)
Note sure this is a dupe. Need clearer explanation of what is going on.

Jonathan, please provide detailed steps to reproduce with what you observe is broken vs what is expected.  Thank you.
Flags: needinfo?(twalker) → needinfo?(jonathan)
Whiteboard: dupme → dupeme
(Reporter)

Comment 3

3 years ago
Still same with version above.
There used to be bug 946932 for e10s

Steps:
Clean nightly profile (ie e10s enabled)
Install flashblock and restart
Visit http://www.adobe.com/uk/software/flash/about/
Flash is blocked correctly
Customize toolbar and add the flashblock button
Click button to disable blocking. (Shows green circle)
Click refresh

Expect flash to load. Instead flash content is still behind block.
Flags: needinfo?(jonathan)

Comment 4

3 years ago
Same thing when things are whitelisted by type:

Flashblock> settings> uncheck "Block HTML5 as well"

Expected: HTML5 videos unblocked.

Result: Nah, still blocked.

It works correctly when e10s is disabled.
(Assignee)

Updated

3 years ago
Blocks: 1192022
(Assignee)

Comment 5

3 years ago
As noted in https://bugzilla.mozilla.org/show_bug.cgi?id=1192022#c4 I hope to fix this by this week.
Assignee: nobody → g.maone
(Assignee)

Comment 6

3 years ago
Created attachment 8657638 [details]
Flashlock version working around this bug

This is a 1.5.19 release candidate, based on the version uploaded by Philip Chee in comment 1, which apparently fixes this bug.

Philip, could you please review it and, if it looks good to you, merge and submit to AMO?
Flags: needinfo?(philip.chee)

Comment 7

3 years ago
Will do. Thanks.
(Assignee)

Comment 8

3 years ago
(In reply to Philip Chee from comment #7)
> Will do. Thanks.

Phil, any news? Firefox 42 is behind the corner now...
Version: 35 Branch → Trunk

Comment 9

3 years ago
> Phil, any news? Firefox 42 is behind the corner now...
I've just integrated your changes. Looks good. I'll upload a new version to AMO soon-ish.
Flags: needinfo?(philip.chee)
(Assignee)

Comment 10

3 years ago
Fixed and submitted to AMO, https://addons.mozilla.org/en-US/firefox/addon/flashblock/versions/?page=1#version-1.5.19
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → FIXED
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.