Closed Bug 1147891 Opened 6 years ago Closed 6 years ago

Intermittent test_bookmarks_html.js,test_bookmarks_json.js | xpcshell return code: 0

Categories

(Toolkit :: Places, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox38 --- unaffected
firefox39 --- fixed
firefox40 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: RyanVM, Assigned: mak)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Attached file test log
No description provided.
This test has been stable for a long time. Any ideas what might have changed that recently?
Flags: needinfo?(mak77)
I'm not sure, cause there is no failure reported in the log, only that the test exits with a "failure" value (but it didn't crash?!). It's really mysterious.
I can only hope the conversion to Bookmarks.jsm API will fix it by itself.

The alternative could be to add a keyword check, maybe there's something related to recent keyword changes, but it would be a blind fix, not sure it would help at all.
Depends on: 1095426
Flags: needinfo?(mak77)
Summary: Intermittent test_bookmarks_json.js | xpcshell return code: 0 → Intermittent test_bookmarks_html.js,test_bookmarks_json.js | xpcshell return code: 0
this reports something more useful

06:03:00 INFO - "CONSOLE_MESSAGE: (warn) [JavaScript Error: "NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIAnnotationService.setPageAnnotation]" {file: "resource://gre/modules/PlacesUtils.jsm" line: 1440}]" 

and later

06:03:00 INFO - Unexpected exception NS_ERROR_NOT_AVAILABLE: Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIAnnotationService.getItemAnnotation]
06:03:00 INFO - checkItem/<@/builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js:333:1
06:03:00 INFO - checkItem@/builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js:287:10
06:03:00 INFO - checkItem@/builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js:287:10
06:03:00 INFO - Promise*promiseAsyncUpdates@resource://testing-common/PlacesTestUtils.jsm:110:1
06:03:00 INFO - test_import_chromefavicon@/builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_bookmarks_html.js:220:9
The problem is that we should be using the new keywords data for backups and html exports, otherwise we are not exporting/importing properly post data for keywords...
Depends on: 1148466
No longer depends on: 1095426
should now be fixed by the dependency...
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee: nobody → mak77
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.