Closed Bug 1147945 Opened 5 years ago Closed 5 years ago

Make the buffer size and sample frequency a configurable pref

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

x86
macOS
defect
Not set

Tracking

(firefox40 fixed)

RESOLVED FIXED
Firefox 40
Tracking Status
firefox40 --- fixed

People

(Reporter: fitzgen, Assigned: jsantell)

References

Details

Attachments

(1 file, 5 obsolete files)

And maybe expose it in devtools UI too?
Assignee: nobody → jsantell
Status: NEW → ASSIGNED
Attached patch 1147945-buffer-size.patch (obsolete) — Splinter Review
Can't build the new perf tool for some reason, so this is another thing added to the todo stack of fx40
Summary: Make the buffer size a configurable pref → Make the buffer size and sample frequency a configurable pref
Duplicate of this bug: 1143598
Adding sample frequency here too from bug 1143598
Comment on attachment 8588393 [details] [diff] [review]
1147945-buffer-size.patch

Review of attachment 8588393 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/performance/test/head.js
@@ +4,5 @@
>  
>  const { classes: Cc, interfaces: Ci, utils: Cu, results: Cr } = Components;
>  
>  let { Services } = Cu.import("resource://gre/modules/Services.jsm", {});
> +let { Preferences } = Cu.import("resource://gre/modules/Preferences.jsm", {});

Cool
Attachment #8588393 - Flags: review?(vporof) → review+
https://hg.mozilla.org/integration/fx-team/rev/f937e8d943d8
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
This is causing a very spammy error in every mochitest-other run:
TypeError: this is null: DT_connectToProfiler@resource:///modules/devtools/gDevTools.jsm:1222:35
Flags: needinfo?(jsantell)
It's actually so spammy during mochitest-dt runs that it blocks real failures from being visible to the log parser. Sorry, I need to back this out until it can be resolved.
https://hg.mozilla.org/integration/fx-team/rev/1667a264fcb2
Flags: needinfo?(jsantell)
Thanks, Ryan -- checking it out now, guessing it's a rebase issue
Should be reattempted after bug 1077464 lands
Depends on: 1077464
Not fixed on fx-team after back out, and decided to land bug 1145824 before this
No longer blocks: 1145824
Depends on: 1145894
Whiteboard: [fixed-in-fx-team]
I meant bug 1145824.
Depends on: 1145824
No longer depends on: 1145894
Rebased
Attachment #8592074 - Attachment is obsolete: true
Attachment #8597564 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/d94e535e171c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 40
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.