If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove nsIProgrammingLanguage

RESOLVED DUPLICATE of bug 1149830

Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 1149830
3 years ago
2 months ago

People

(Reporter: mccr8, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
There are only a few bits of this left from a time when work was being done to support multiple scripting languages in Gecko. It probably would not be hard to remove the remainder.
(Reporter)

Updated

3 years ago
Depends on: 1147951
(Reporter)

Updated

3 years ago
Depends on: 1147967
(Reporter)

Updated

3 years ago
Depends on: 1148070
(Reporter)

Updated

3 years ago
Depends on: 1149807
(Reporter)

Updated

3 years ago
Depends on: 1149830
(Reporter)

Updated

3 years ago
Depends on: 1150674
(Reporter)

Comment 1

3 years ago
I spent some time looking through addons MXR for users of nsIProgrammingLanguage.  We'll probably have to leave in JAVASCRIPT for a while, because many addons use it in the nsIClassInfo boilerplate.  It could be turned into a getter than warns, in the hope that our descendents might one day remove it.  But the rest of it looks like it can go.
(Reporter)

Updated

3 years ago
Depends on: 1150917
(Reporter)

Updated

3 months ago
Blocks: 1347507
(Reporter)

Comment 2

2 months ago
This is getting removed entirely in bug 1149830, so we can close this once that lands.
Fixed by bug 1149830.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149830
You need to log in before you can comment on or make changes to this bug.