Deleting history entries from "Older than X days" folder doesn't update window

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
17 years ago
15 days ago

People

(Reporter: duvall, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When you use the keyboard to delete an entry from the history (arrow to it and
hit the delete key), it normally disappears and the highlight moves down an
entry.  But if you're in the folder labeled "Older than X days", the entry
doesn't disappear from the view.  It does disappear from the model, though,
since closing and re-expanding the containing site makes it go away.

This also appears to be the case when selecting "Delete" from the context menu.

This is using a 20011207 build.

Comment 1

17 years ago
is this still a problem in recent builds or 0.9.9?

i think history used to use <tree> before the whole <outliner> -> <tree> change
and this could have been a <tree> (former one) problem.
(Reporter)

Comment 2

17 years ago
This is still a problem with at least a 2002-03-15 build, which claims to be
0.9.9+.  I'll check a more recent one later today.

Comment 3

17 years ago
yeah. the checkin i was referring to occured somewhere around 3-29 so you need a
pretty recent build.
(Reporter)

Comment 4

17 years ago
Yeah, I see it with a 2002-04-05 build, too.
worksforme (Linux, 1.0RC1).

Danek, how about you, still on 1.0RC1?
(Reporter)

Comment 6

17 years ago
Yes, I still see it, having checked out the RC1 branch this morning at about one
o'clock.  I tried creating a brand new profile and copying a history.dat file
over from another profile, and it showed the same problem, both in the Modern
and Classic themes, if that should make any difference.

The only thing that isn't completely up-to-date (that I can think of) is libIDL,
which is 0.6.5 -- would that affect this at all, and should I upgrade?  Anything
else not directly related to the code that might be the cause?

Comment 7

17 years ago
Do you get any messages in the javascript console?
(Reporter)

Comment 8

17 years ago
Nope, I don't see a thing.

Comment 9

16 years ago
Is this still a problem in a current build?

Either I don't understand the bug or it WFM.

pi
(Reporter)

Comment 10

16 years ago
It was still not working on a May 29 build, but I didn't try a fresh profile to
make sure.  I'm away from my computer for another week, so I won't be able to
check for a little bit -- don't close this bug until I've checked back.
(Reporter)

Comment 11

16 years ago
Just checked, and I see this on a MacOS X build of 1.0.  I'm happy to share the
profile that demonstrate this behavior, if that would help anyone reproduce the
problem.
(Reporter)

Comment 12

16 years ago
I'm still seeing this, on Linux, in a 2002061116 build, with a fresh profile. 
Again, I created a new profile and copied a history.dat file from an older
profile into the new profile.  Could it be a corrupt history.dat that's causing
this behavior?

Comment 13

16 years ago
WFM: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a) Gecko/20020610

Try in a new profile (without the old history), please.

pi

Comment 14

16 years ago
no response from reporter for >30 days. resolving WFM.

Danek, if you're still having this problem, please try with a new profile as
requested, and if it still happens, you can reopen this bug. thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 15

4 years ago
i have the same problem for windows7 (in Firefox version 26.4.0).
my history is older then 6 months and the size of profile folder 260mb.

the description step by step:
i created new profile and imported my old profile files (more then 260mb). 
after that, i opened the history tab and selected the item "remove older then 6month". 
this produce a endless loop in firefox and firefox does not response.

Updated

15 days ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.