If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Raptor] Update version in Gaia v2.2

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::PerformanceTest
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Eli, Assigned: Eli)

Tracking

unspecified
2.2 S9 (3apr)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master unaffected)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
Raptor is currently at v0.2.0 in Gaia v2.2. Current Raptor stands at v1.2.1, and will hit v1.2.2 once bug 1147949 lands. We need to update this to the latest version so that Raptor can be operational in the v2.2 branch.

Comment 1

3 years ago
Created attachment 8584557 [details] [review]
[gaia-node-modules] eliperelman:bug-1148058 > mozilla-b2g:v2.2
(Assignee)

Comment 2

3 years ago
Comment on attachment 8584557 [details] [review]
[gaia-node-modules] eliperelman:bug-1148058 > mozilla-b2g:v2.2

All the Raptor patches in this roll-up were reviewed by rwood. Carrying over his r+ for the v2.2 branch.
Attachment #8584557 - Flags: review+
(Assignee)

Comment 3

3 years ago
Comment on attachment 8584557 [details] [review]
[gaia-node-modules] eliperelman:bug-1148058 > mozilla-b2g:v2.2

Requesting uplift of Raptor package update to v1.2.2 in the v2.2 branch of gaia-node-modules. (There will still need to be a subsequent update to Gaia to bump the package version.)

[Bug caused by] (feature/regressing bug #): bug 782751
[User impact] if declined: no user impact, these changes are test-only
[Testing completed]: manually, these changes *are* for tests
[Risk to taking this patch] (and alternatives if risky): won't be able to use Raptor to test v2.2 performance
[String changes made]: n/a
Attachment #8584557 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

3 years ago
Attachment #8584557 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+

Comment 4

3 years ago
Created attachment 8584801 [details] [review]
[gaia] eliperelman:bug-1148058 > mozilla-b2g:v2.2
(Assignee)

Comment 5

3 years ago
Comment on attachment 8584801 [details] [review]
[gaia] eliperelman:bug-1148058 > mozilla-b2g:v2.2

Carrying over r+ from kgrandon on bug 1129687 on the gaia patch, which is what this patch is replicating for v2.2. See https://github.com/mozilla-b2g/gaia/pull/28274

Requesting uplift to v2.2 to enable Raptor performance tests for v2.2

[Bug caused by] (feature/regressing bug #): bug 1129687
[User impact] if declined: none, this feature is test-only
[Testing completed]: manually running the Raptor performance tests against v2.2 with this patch run successfully
[Risk to taking this patch] (and alternatives if risky): no risk, only testing changes and gaia support for them
[String changes made]: n/a
Attachment #8584801 - Flags: review+
Attachment #8584801 - Flags: approval-gaia-v2.2?(bbajaj)

Updated

3 years ago
Attachment #8584801 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
(Assignee)

Comment 6

3 years ago
In v2.2: https://github.com/mozilla-b2g/gaia/commit/cc11248ab69f13e89416c8e6bb2e184187e72088
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → unaffected
Target Milestone: --- → 2.2 S9 (3apr)
You need to log in before you can comment on or make changes to this bug.