crash in js::PutEscapedStringImpl

VERIFIED FIXED in Firefox 39

Status

()

defect
--
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: rowbot, Unassigned)

Tracking

({crash, regression, reproducible})

Trunk
mozilla39
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox38 unaffected, firefox39 fixed)

Details

(crash signature)

Attachments

(1 attachment)

Reporter

Description

4 years ago
While trying to profile a performance issue with playing 4K videos on YouTube, all tabs would crash shortly after clicking Analyze in the Gecko Profiler.  This crash happened about 75% of the time.  I am using the latest 64-bit nightly on Windows 7.  e10s is enabled.

STR:
1) Install Gecko Profiler[1] addon
2) Play a YouTube video at 4K using the HTML5 player (I was profiling [2])
3) Profile during playback for at least 10-15 seconds
4) Click Analyze in the Gecko Profiler addon

Actual results:
All tabs crashed.

Expected results:
Profile should be loaded in cleopatra.

bp-f7c38532-253f-47d8-b8d7-253842150326
bp-c56f0787-6257-457d-b855-3d3cc2150326
bp-911feb79-c66f-4fee-98b2-a8b992150326

[1] https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Profiling_with_the_Built-in_Profiler
[2] https://www.youtube.com/watch?v=s0MDY9fl-IA

Updated

4 years ago
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: reproducible

Comment 2

4 years ago
Sorry spam,
please ignore comment#1
Keywords: regression

Updated

4 years ago
No longer blocks: 1146883

Comment 3

4 years ago
[Tracking Requested - why for this release]: Crash since Nightly39

I think the following regression range is probably correct.

Regression window(m-c):
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2a404169de2d&tochange=f949be6cd23e

Regression window(m-i):
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8d14c6661f00&tochange=8bd7b499e291
Blocks: 1143860
Flags: needinfo?(shu)
Keywords: regression

Comment 5

4 years ago
Alice or Trevor, could you confirm that the patch fixes the crash for you?
Flags: needinfo?(shu) → needinfo?(smokey101stair)
Attachment #8584825 - Flags: review?(kvijayan) → review+

Comment 6

4 years ago
(In reply to Shu-yu Guo [:shu] from comment #5)
> Alice or Trevor, could you confirm that the patch fixes the crash for you?

Build from m-c tip 67f8d63b2cad : crashes
Build from m-c tip 67f8d63b2cad + applied attachment 8584825 [details] [diff] [review] : no crash (attempted 5 times)

So, the patch seems to fix the crash problem on Windows7.
Reporter

Comment 7

4 years ago
Clearing ni? since Alice answered already.  I'm not setup to build Firefox right now, but I'll be sure to test it out when it lands in nightly.
Flags: needinfo?(smokey101stair)
https://hg.mozilla.org/mozilla-central/rev/1715529498c8
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Reporter

Comment 10

4 years ago
This appears to be fixed.  Thanks!
Status: RESOLVED → VERIFIED
Sounds like we don't need to track this, since it's fixed on 39, but please nominate it again if there's any problem.
You need to log in before you can comment on or make changes to this bug.