Closed Bug 1148078 Opened 5 years ago Closed 5 years ago
Replace "Logical" w/ "Flex
Relative" in flexbox functions/comments about [main-axis,cross-axis] positions & sizes
Before switching flexbox layout to logical coordinates in bug 1079155, we should get rid of misleading uses of the term "Logical" in nsFlexContainerFrame (which predate the logical-coordinates work). I used "logical position/size" to refer to "main-axis/cross-axis position/size". For now, I'm going to switch to call these "flex-relative" instead of "logical". (We may come up with a better term down the line; ideally, we should use something that applies to flex & grid. For now, "FlexRelative" is pretty clear, though, and we can do search-and-replace later if we think of something better.)
I'm also changing some usages of position/posn/pos in the tweaked code to "coord" instead. (so e.g. "PhysicalPosFromLogicalPos" is now known as "PhysicalCoordFromFlexRelativeCoord"). I'm making this change since "position" is ambiguous about whether it's 1- or 2-dimensional value. "Coord" is a bit less ambiguous. (Elsewhere in this file, I still have e.g. FlexItem::GetMainPosition/GetCrossPosition, but I think that's less ambiguous.)
You need to log in before you can comment on or make changes to this bug.