DirectWrite doesn't render font in SoundCloud's audio track player

RESOLVED WORKSFORME

Status

()

Core
Graphics: Text
RESOLVED WORKSFORME
3 years ago
10 months ago

People

(Reporter: Rodrigo, Unassigned)

Tracking

37 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [gfx-noted][platform-rel-Soundcloud])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8584064 [details]
soundcloud directwrite problem.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150324194038

Steps to reproduce:

1) Enable gfx.font_rendering.directwrite.enabled
2) Go to soundcloud.com and notice that the font that displays the duration/time elapsed on an audio track is not being rendered.


Actual results:

The font that displays the duration/time elapsed on an audio track is not being rendered.


Expected results:

DirectWrite should be able to render that particular font.
(Reporter)

Updated

3 years ago
Component: Untriaged → Graphics: Text
Product: Firefox → Core
Can you paste the graphics section of your about:support?
What happens if you reset gfx.font_rendering.directwrite.enabled to the default?
(Reporter)

Comment 3

3 years ago
Controladores do adaptador	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Data do controlador	12-20-2014
Descrição do adaptador	Intel(R) HD Graphics 3000
DirectWrite ativado	false (6.2.9200.16492)
GPU #2 ativo	false
ID do dispositivo	0x0116
ID do fornecedor	0x8086
ID do Subsistema	1657103c
Janelas aceleradas por GPU	0/1 Basic (OMTC)
Parâmetros ClearType	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
Processador WebGL	Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D11 vs_5_0 ps_5_0)
RAM do adaptador	Unknown
Versão do controlador	9.17.10.3517
windowLayerManagerRemote	true
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0


Resetting gfx.font_rendering.directwrite.enabled to default (false) renders that particular font without any problem.
(Reporter)

Comment 4

3 years ago
I've disabled DirectWrite so thats why it states it is not activated.

Also, I have no idea why Firefox is not using my AMD Radeon HD 6770M as the default graphics card. If I enable hardware acceleration, every html5/flash video is just pitch black.
DirectWrite is not really supported for use without Direct2D, so we're probably not going to do anything there. Bug 1097321 might help with the problem that you're seeing.
Depends on: 1097321
Whiteboard: [gfx-noted]
platform-rel: --- → ?
Whiteboard: [gfx-noted] → [gfx-noted][platform-rel-Soundcloud]

Comment 6

11 months ago
Hey Jeff - Can you take a look at this and see if it is still reproducible?
Flags: needinfo?(jmuizelaar)
This is Windows Server 2008; given how long ago it was that this was reported, that it was a non-defaultpreference, that we made a lot of changes to DirectWrite since then and that we can't contact the original reporter (needinfo is blocked), I'm going to close it.  Please reopen if this is still a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME
Flags: needinfo?(jmuizelaar)
You need to log in before you can comment on or make changes to this bug.