implement main nav (mobile)

RESOLVED FIXED in 2015-04-07

Status

Marketplace
Consumer Pages
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ddurst, Assigned: ngoke)

Tracking

2015-04-07
x86
Mac OS X
Points:
---
Dependency tree / graph

Details

(Reporter)

Description

3 years ago
Update navigation to match new design on mobile.
(Assignee)

Updated

3 years ago
Assignee: nobody → kngo
(Assignee)

Comment 1

3 years ago
https://github.com/mozilla/fireplace/pull/1100

To preview it on -dev, go to the Debug page, and click on 'Enable new mkt-nav'.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2015-03-31

Comment 2

3 years ago
Verifying on FFOS 2.0 Flame/ Android 4.2.1 (Win 7) and observing the screenshots from GitHub (https://github.com/mozilla/fireplace/pull/1100), there are the following differences:

1. The nav button does not change according to it's state - http://screencast.com/t/PJGhgqfBcrn 

2. In app details page there is no nav button (neither in collection listing pages or categories) - http://screencast.com/t/59nebEoIw

3. If you select a category from the end of the list (i.e.Sport), then you navigate to homepage, when you access the Categories again the list is not displayed from the beginning (i.e. Games) and you have to scroll. 

Please tell us if these are intended.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 3

3 years ago
1. Is that reproducing on only for Firefox for Android? The nav button should change state depending on whether the mobile nav is visible whether we are hovering over the button.

2. Yeah, that changed. There is no nav button on "leaf" / deeper pages. It only shows up on the "root" / main pages. Just as the current nav currently doesn't show up on App Detail pages.

3. Neither intended nor unintended. I don't think it is of consequence that the subnav/category nav remembers where you left off.

Comment 4

3 years ago
Is reproducing for FFOS and Android. 

I'll try to explain what we observed, checking the nav button states presented on specifications (https://www.dropbox.com/s/vub9eg304ohox1i/MP_UX_Navigation%20Spec%20-%20150311.pdf?dl=0), and verifying on FFOS (2.0) and Android(4.2.1):
-the nav button has a "gray state" when is not selected, but also a normal state
-a "selected state" appears only for a few seconds, when you tap the button
It's a little bit confusing. 

Also the lines are unequal, don't know if this is intended. (http://screencast.com/t/JbnnVmU6P)
(Assignee)

Comment 5

3 years ago
1. I fix the button states to remove the Grey state. It was because mobile devices will keep a button as "active" even when you have let go of it.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: 2015-03-31 → 2015-04-07
(Assignee)

Comment 6

3 years ago
Notes on mobile:

1. The Flame doesn't show the main nav animating when it first opens (although opening the categories menu will animate). This is mostly likely a hardware or device issue trying to animate too much content at once. We will have to ignore this.
2. The Nav was flickering being the header when the Nav was closed and you scrolled up and down on mobile. I have addressed that

Comment 7

3 years ago
For a better tracking, we decided to log separate issues regarding the implementation of the new nav menu.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

3 years ago
Depends on: 1150804
(Assignee)

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.