Intermittent conversion_banner_test.js | Message Type Conversion Banner Message Type Conversion Banner for new threads MMS to email conversion and reminders

RESOLVED FIXED in Firefox OS master

Status

Firefox OS
Gaia::SMS
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: KWierso, Assigned: azasypkin)

Tracking

({intermittent-failure})

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)
intermittent-failure

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master fixed)

Details

(Whiteboard: [sms-sprint-2.2S11])

Attachments

(1 attachment)

Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 7

3 years ago
Will take a look what is going on here.
Flags: needinfo?(azasypkin)
Comment hidden (Treeherder Robot)
Created attachment 8596548 [details] [review]
[gaia] azasypkin:bug-1148152-conversion-banner-test > mozilla-b2g:master
The issue here is that in suite "setup" function we try to create two threads manually (create and send new message) and fail to create the second one - tap on send button doesn't work for some unknown to me reason.

In attached PR I replaced manual creation steps with predefined workload mechanism introduced in patch for bug 1043903, so this should fix intermittent failures here, but I still want to understand why marionette doesn't process send button tap correctly.
Flags: needinfo?(azasypkin)
QA Contact: azasypkin
Hardware: x86_64 → ARM
Assignee: nobody → azasypkin
QA Contact: azasypkin

Comment 11

3 years ago
I'd like to see this land ASAP. It will enable me to land bug 1141792. I can't right now because this test is too flacky.
Comment on attachment 8596548 [details] [review]
[gaia] azasypkin:bug-1148152-conversion-banner-test > mozilla-b2g:master

Hey Julien,

I didn't have time to investigate the root cause here yet, but how do you feel about landing something like this in the meantime? It doesn't change main test idea.

Thanks!
Attachment #8596548 - Flags: review?(felash)
Comment on attachment 8596548 [details] [review]
[gaia] azasypkin:bug-1148152-conversion-banner-test > mozilla-b2g:master

r=me let's land this

I don't reproduce on master, but with this patch it feels cleaner so if this fixes the issue as well then let's go.

Still it's not reassuring that I couldn't reproduce at all while you reproduce at first try. Maybe we have an issue somewhere that will come back and bite us. Although the new architecture should change lots of things here.
Attachment #8596548 - Flags: review?(felash) → review+
Thanks for review! I'll try to keep eye on the issue.
Status: NEW → ASSIGNED
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
v2.2: https://github.com/mozilla-b2g/gaia/commit/8612599f1737b2d8d204827c3bffbb349d64c6fe
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S11 (1may)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

3 years ago
Whiteboard: [sms-sprint-2.2S11]
You need to log in before you can comment on or make changes to this bug.