Building with --disable-eme fails with compile error

RESOLVED DUPLICATE of bug 1148203

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1148203
3 years ago
3 years ago

People

(Reporter: cajbir, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
On Linux building with --disable-eme I get the following error:

 1:45.07 dom/media/fmp4/MP4Reader.cpp: In member function ‘void mozilla::MP4Reader::Update(mozilla::MP4Reader::TrackType)’:
 1:45.07 dom/media/fmp4/MP4Reader.cpp:758:44: error: ‘class mozilla::AbstractMediaDecoder’ has no member named ‘GetCDMProxy’
 1:45.07        nsRefPtr<CDMProxy> proxy = mDecoder->GetCDMProxy();
 1:45.07                                             ^
 1:45.07 dom/media/fmp4/MP4Reader.cpp:761:12: error: invalid use of incomplete type ‘class mozilla::CDMProxy’
 1:45.07        proxy->GetSessionIdsForKeyId(crypto.key, crypto.session_ids);
 1:45.07             ^
 1:45.07 In file included from dom/media/fmp4/MP4Reader.h:12:0,
 1:45.07                  from dom/media/fmp4/MP4Reader.cpp:7:
 1:45.07 dom/media/fmp4/PlatformDecoderModule.h:34:7: error: forward declaration of ‘class mozilla::CDMProxy’
 1:45.07  class CDMProxy;
 1:45.07        ^
 1:45.07 In file included from ../../../dist/include/nsAutoPtr.h:11:0,
 1:45.07                  from ../../../dist/include/StreamBuffer.h:10,
 1:45.07                  from ../../../dist/include/MediaInfo.h:14,
 1:45.07                  from ../../../dist/include/AbstractMediaDecoder.h:11,
 1:45.07                  from ../../../dist/include/MediaDecoderReader.h:9,
 1:45.07                  from dom/media/fmp4/MP4Reader.h:10,
 1:45.07                  from dom/media/fmp4/MP4Reader.cpp:7:
 1:45.07 ../../../dist/include/nsRefPtr.h: In instantiation of ‘nsRefPtr<T>::~nsRefPtr() [with T = mozilla::CDMProxy]’:
 1:45.07 dom/media/fmp4/MP4Reader.cpp:758:56:   required from here
 1:45.07 ../../../dist/include/nsRefPtr.h:60:7: error: invalid use of incomplete type ‘class mozilla::CDMProxy’
 1:45.08        mRawPtr->Release();
 1:45.08        ^
 1:45.08 In file included from dom/media/fmp4/MP4Reader.h:12:0,
 1:45.08                  from dom/media/fmp4/MP4Reader.cpp:7:
 1:45.08 dom/media/fmp4/PlatformDecoderModule.h:34:7: error: forward declaration of ‘class mozilla::CDMProxy’
 1:45.08  class CDMProxy;
 1:45.08        ^
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1148203
You need to log in before you can comment on or make changes to this bug.