<INPUT TYPE=FILE...> ignores CSS input{} settings

VERIFIED DUPLICATE of bug 52500

Status

()

VERIFIED DUPLICATE of bug 52500
17 years ago
17 years ago

People

(Reporter: thimo, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6+)
Gecko/20011211
BuildID:    2001121103

In the webapplication I'm building I have a seperate CSS page in which I set the
following:

input { 
	font-family: Verdana, Arial, Helvetica, sans-serif; 
	font-size: 10; 
	font-weight: normal; 
	color: #000000 }

The upload control <INPUT TYPE=FILE NAME=...> doesn't seem to be bothered there
is a CSS definition for 'input' and displays in the default style.

Reproducible: Always
Steps to Reproduce:
1. Open a page with an upload control

Expected Results:  I would expect that the upload control would be displayed in
the style as defined for 'input', like it does on IE 5.5.
Via bug 65597, this is a dupe of bug 52500.

*** This bug has been marked as a duplicate of 52500 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Verified.  Form controls do not fall into the purview of CSS, since it is
impossible to actually describe them in the language of CSS.  CSS3 is attempting
to rectify that...
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.