Duplicate folder created by Bookmark All Tabs

RESOLVED DUPLICATE of bug 381299

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 381299
3 years ago
3 years ago

People

(Reporter: Patrick O'Keeffe, Unassigned)

Tracking

36 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150306140238

Steps to reproduce:

Right-click tabs, choose Bookmark All Tabs, select any existing folder, and click Add Bookmarks.



Actual results:

 A new folder containing the bookmarks is created with the same name as selected existing folder.


Expected results:

I expected the bookmarks would be added to the folder I selected. "Add bookmarks" is what I clicked. It's a little surprising you can have two identically-named adjacent folders.

Comment 1

3 years ago
Reproduced with
firefox-36.0.en-US.linux64
2015-04-01-08-51-08-mozilla-central-firefox-40.0a1.ru.linux-x86_64

Probably a case of bug 633487.

Note that there is a confusing feature that is not this bug: when you select a folder and uncollapse it, you see there the folder you are going to create.
Status: UNCONFIRMED → NEW
QA Whiteboard: [DUPEME?]
Component: Untriaged → Bookmarks & History
Ever confirmed: true
See Also: → bug 633487
It's simple to just name the folder, when the dialog opens the name field is focused too, so it's not some hidden operation.
See the duped to bug for why we don't want to undupe names.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 633487
(Reporter)

Comment 3

3 years ago
I was thinking more bug 381299 "Bookmark all tabs into an existing folder instead of creating a new one."

Updated

3 years ago
Duplicate of bug: 381299
You need to log in before you can comment on or make changes to this bug.