[E-mail]The notification of email won't disappear after reading the mail

RESOLVED WORKSFORME

Status

P2
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

log
1.54 MB, application/octet-stream
Details
45.10 KB, image/x-png
Details
(Reporter)

Description

4 years ago
+++ This bug was initially created as a clone of Bug #789479 +++
 Created an attachment (id=946188)
 log
 
 DEFECT DESCRIPTION:
 The notification of email won't disappear after reading the mail
  REPRODUCING PROCEDURES:
 1.create an Exchange mail account
 2.receive a mail from other account
 3.tap the notification to read the mail
 4.the notification won't disappear -->KO
 
 中文:
 1.创建一个Exchange邮箱账户(hotmail)
 2.从其他账户接收一个邮件
 3.点击状态栏的通知图标去读取邮件
 4.状态栏的通知图标不会消失-->KO
 5.Soul 3.5FF是可以正常消失的。Fire C 2G 使用Gmail邮箱是可以正常消失的。
  EXPECTED BEHAVIOUR:
 The notification of email will disappear after reading the mail
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
 ++++++++++ end of initial bug #789479 description ++++++++++
(Reporter)

Comment 1

4 years ago
Created attachment 8584318 [details]
log
(Reporter)

Comment 2

4 years ago
Created attachment 8584319 [details]
PIC
(Reporter)

Comment 3

4 years ago
Hi guys, 
    I follow the code and find when click notification enter email, in the app_messages.js  onNotification function,the msg.tag is undefined that made the notification does not close. but I couldn't find where the msg come from, could you give me some advice?
(Reporter)

Comment 4

4 years ago
Hi, I find the reason that set the message in mail_app.js, that's will be ok
Based on the canForward error in the log and the mention of the Fire C, it appears this is for Fx OS v1.3.  Many notification-related bugs have been fixed since then (this one may have just been a platform issue?), so I'm marking this RESOLVED WORKSFORME, but if someone wants to figure out what bug to dupe this to, that could be a more accurate state.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.