[Nexus 5][Camera] Sometimes the camera is set to high resolution when attaching video from message.

NEW
Unassigned

Status

Firefox OS
Gaia::Camera
3 years ago
2 years ago

People

(Reporter: Alissa(leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8584386 [details]
logca1.txt

[1.Description]:
[Nexus 5 V2.2&v3.0][Camera]While we new a message and add attachment from camera,
amera is set to high distinguishability so that we just can take a short video. 
Found at:16:17
see attachments:logcat1.txt, 1.3gp.

[2.Testing Steps]: 
1.Launch message.
2.Tap NEW button.
3.Tap add attachment button.
4.Tap camera.
5.Switch to video mode.
6.Try to focus on something you want to take.
7.Tap record button.

[3.Expected Result]: 
7.Just 1-2 sec can be recorded.

[4.Actual Result]: 
7.The video recorder should be set to a constant.

[5.Reproduction build]: 

Device:Nexus5 2.2[Affected]
Build ID               20150326002504
Gaia Revision          e59ac067a1d22b7a72cbebc892ec652723f2a557
Gaia Date              2015-03-26 00:02:53
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/04b4b9d1faae
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150326.042055
Firmware Date          Thu Mar 26 04:21:09 EDT 2015
Bootloader             HHZ12d

Nexus 5 v3.0[Affected]
Build ID               20150326160206
Gaia Revision          525c341254e08f07f90da57a4d1cd5971a3cc668
Gaia Date              2015-03-26 16:34:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/59554288b4eb
Gecko Version          39.0a1
Device Name            hammerhead
Firmware(Release)      5.0
Firmware(Incremental)  eng.cltbld.20150326.193418
Firmware Date          Thu Mar 26 19:34:37 EDT 2015
Bootloader             HHZ12d

Flame 2.2[Unaffected]:
Build ID               20150326164141
Gaia Revision          6d0174e28576f2f93e696a43d1ac3b03340117f6
Gaia Date              2015-03-26 21:47:33
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/820c2f2e817a
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150326.201153
Firmware Date          Thu Mar 26 20:12:05 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Occasionally Recurrence,3/10

[7.TCID]: 
Free Test

[8.Note]:
This issue doesn't exist on flame 2.2
(Reporter)

Comment 1

3 years ago
Created attachment 8584387 [details]
1.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Summary: [Nexus 5][Camera]Sometimes the camera is set to high distinguishability while add video from carema in message. → [Nexus 5][Camera] Sometimes the camera is set to high resolution when attaching video from message.
Flags: needinfo?(hcheng)
I cannot reproduce this issue if I closed all the other applications or restart the phone.
I think it might be a gecko problem. NI camera developer. David, could you take a look?
Flags: needinfo?(hcheng) → needinfo?(dflanagan)
Alissa: What is the resolution of the 1-second video that is recorded when this bug occurs?  When the bug does not occur, what is the resolution in that case?

Hermes: are you able to reproduce this at all?

Mike: what is the smallest video size that the Nexus 5 hardware supports, do you know? (In order to enable sending videos by MMS, we need to have something tiny like QVGA, even though that would look ridiculously small on a nexus 5 screen.)  Can you think of any reason why the camera might report different video resolutions at different times? Or any reason that it might fail to honor a requested video resolution?

Justin: I'm setting needinfo for you because the fact that this is an intermittent bug suggests that it is not just a matter of asking Mike to enable a smaller recording size and it might be something that you have to fix.
Flags: needinfo?(mhabicher)
Flags: needinfo?(jdarcangelo)
Flags: needinfo?(huayu.li)
Flags: needinfo?(hcheng)
Flags: needinfo?(dflanagan)
Yes, I can reproduce it sometimes. Sometimes, after that I closed all other apps, it can record much longer.
Flags: needinfo?(hcheng)
(Reporter)

Comment 5

3 years ago
(In reply to David Flanagan [:djf] from comment #3)
> Alissa: What is the resolution of the 1-second video that is recorded when
> this bug occurs?  When the bug does not occur, what is the resolution in
> that case?
Hi David,
1.while the 1-second video recorded, sometimes, it can be added as attachment, sometimes, it will back to viewfinder[is this need to new a bug?]
2.When the bug doesn't occur, a Fuzzy video will be recorded and can be added as attachments.
Flags: needinfo?(huayu.li)
In response to comment 3, the nexus-5-l camera supports the following video resolutions: 1080p (aka "high" -- the default), 720p, 480p, cif, and qvga (aka "low").
Flags: needinfo?(mhabicher)
So I'm guessing it is technically not a bug since the default is 1080p (which is a pretty large res).  This bug might also happen on Aries.  should we try to fix it for 2.5?
Flags: needinfo?(dflanagan)
No-Jun: it is a bug. The camera app has code to reduce the video resolution when recording a video to be attached to a message. It has worked in the past. I don't know whether this is an across the board regression or if it is really something that only affects Nexus 5.

If it affects Aries, then it should be a high-priority bug.
Flags: needinfo?(dflanagan)
Per Comment 8, adding qawanted to see whether it repros in Aries
Keywords: qawanted
After 15 attempts I was always able to take a 22 second video with the Aries device.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150729013848
Gaia: 21256d7665f972255d198f8af81a8df4bd0e0fc4
Gecko: 2ee9895e032c
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
[Tracking Requested - why for this release]:

Based on comment 10, moving this to the backlog.
tracking-b2g: --- → backlog

Updated

2 years ago
Flags: needinfo?(jdarcangelo)
You need to log in before you can comment on or make changes to this bug.