firefox won't start on linux- crashes even in safe mode

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: dhimes, Unassigned)

Tracking

({crash})

36 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.101 Safari/537.36

Steps to reproduce:

Start Firefox both from icon and terminal 
firefox -safe-mode


Actual results:

Checks for add-on compatibility, finds, a single incompatibility (user agent switcher), then crashes no matter if I select "check for updates" or "restart."

BuildID: 20150321175551
CrashTime: 1427457045
Email: xxxxxxxxxxxxxxxx
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1427456672
Notes: OpenGL: NVIDIA Corporation -- GeForce G210M/PCIe/SSE2 -- 3.3.0 NVIDIA 331.113 -- texture_from_pixmap

Also:
Linux dirac 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:28:38 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

and:  
Description:    Linux Mint 17.1 Rebecca





Expected results:

Should have started normally
(Reporter)

Comment 1

4 years ago
On rebooting the machine, it started fine when choosing "Don't check" for incompatible add-on.  Suggest "Works for Me" status for a bit (see if anybody else has trouble), then reject after next update.

Comment 2

4 years ago
(In reply to Dan Himes from comment #0)
> Checks for add-on compatibility, finds, a single incompatibility (user agent
> switcher), then crashes no matter if I select "check for updates" or
> "restart."

What if you move some extensions out of the extensions/ directory and try again to see if any of the extensions causes it?

> BuildID: 20150321175551
> CrashTime: 1427457045

Please open about:crashes, and post here the relevant crash report IDs.
Severity: normal → critical
Flags: needinfo?(dhimes)
Keywords: crash, stackwanted

Updated

4 years ago
See Also: → bug 1006109
(Reporter)

Comment 3

4 years ago
Aleksej,  Thank you.  If it crashes again I will do that.  Right now it's not crashing any more.
Flags: needinfo?(dhimes)

Comment 4

4 years ago
I may have run into the same issue:

Version 	40.0a1
Build ID 	20150403030204

Linux 64 bit

After updating to this version, Nightly instantly crashes on startup (it won't even start, i.e. no browser window will be created), but it still works in safemode.

I've narrowed it down to the Session Manager addon, it can be enabled while in safemode and I can start Nightly normally afterward, but subsequently every interaction with Session Manager instantly crashes Firefox and then it can't be restarted if not in safemode.

Comment 5

4 years ago
Also tested on a clean profile, Session Manager 0.8.1.7pre20141016b instantly crashes Nightly after installing it and then clicking on its icon.

It worked up to Nightly 40.0a1 (20150402030207) which is the latest update for me before rev 20150403030204 .
Comment hidden (offtopic)

Comment 8

4 years ago
(In reply to [:Aleksej] from comment #7)
> Dan, did you have the Session Manager or Tree Style Tab installed?

Sorry, it seems to be Nightly-only.  Does not happen with 37.0, and is newer than this bug report.
Flags: needinfo?(dhimes)
(In reply to msth67 from comment #6)
> https://crash-stats.mozilla.com/report/index/bp-ec9e2ad9-b7d0-45f3-b815-
> d344b2150403

Marking as duplicate of bug #1150906 per this comment, as we have there more information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
See Also: bug 1006109
Duplicate of bug: 1150906

Comment 10

4 years ago
(In reply to Virtual_ManPL [:Virtual] from comment #9)
> Marking as duplicate of bug #1150906 per this comment, as we have there more
> information.

This bug was filed on March 27th (apparently for Firefox stable), while that bug first appears in Nightly of April 3rd.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
Ahhh, yep, I based mainly on hijacked posts about different issue in Comment 4, Comment 5 and Comment 6 which is a duplicate of bug #1150906,
so OP please post your crashlog reports from about:config
Flags: needinfo?(dhimes)
(In reply to Virtual_ManPL [:Virtual] from comment #11)
> from about:config

from about:crashes I meant... :)

Comment 13

4 years ago
(In reply to Virtual_ManPL [:Virtual] from comment #11)
> Ahhh, yep, I based mainly on hijacked posts about different issue 
> 
Sorry I didn't mean to hijack this bug, a quick search on bugzilla turned out this one as being apparently very similar to the issue I was experiencing.
(Reporter)

Comment 14

4 years ago
(In reply to [:Aleksej] from comment #2)
> (In reply to Dan Himes from comment #0)
> > Checks for add-on compatibility, finds, a single incompatibility (user agent
> > switcher), then crashes no matter if I select "check for updates" or
> > "restart."
> 
> What if you move some extensions out of the extensions/ directory and try
> again to see if any of the extensions causes it?
> 
> > BuildID: 20150321175551
> > CrashTime: 1427457045
> 
> Please open about:crashes, and post here the relevant crash report IDs.

OK I will do that when I get back to the box.  Should be 2015-04-06 around 1130-1200 UTC.  Also, fwiw, no Tree Style
Flags: needinfo?(dhimes)
(Reporter)

Comment 15

4 years ago
Report ID 	                                       Date Submitted
bp-f7695151-1983-4a53-9404-4585521504004/01/2015	10:18 AM
bp-77cb560b-c2a8-4f8e-9d43-e9b392150327
	03/27/2015	07:54 AM
bp-57fd1a53-0755-4dca-8e5d-1c6b72150327
	03/27/2015	07:45 AM
bp-025c92ac-dbc6-45cd-841a-d456d2150327
	03/27/2015	07:44 AM
bp-6e5739f3-fec1-4227-a4f2-2dad92150326
	03/26/2015	01:10 PM
(Reporter)

Comment 16

4 years ago
Here are the relevant report IDs, in case this is still going.  I haven't had a problem in days (I'm not sure the 01 Apr report is relevant.

Report ID 	                           Date Submitted
bp-f7695151-1983-4a53-9404-458552150401     04/01/2015	10:18 AM
bp-77cb560b-c2a8-4f8e-9d43-e9b392150327     03/27/2015	07:54 AM
bp-57fd1a53-0755-4dca-8e5d-1c6b72150327     03/27/2015	07:45 AM
bp-025c92ac-dbc6-45cd-841a-d456d2150327     03/27/2015	07:44 AM
bp-6e5739f3-fec1-4227-a4f2-2dad92150326     03/26/2015	01:10 PM

Comment 17

4 years ago
Thank you, Dan.
Crash Signature: [@ nsGlobalWindow::ReallyCloseWindow ]
Keywords: crashreportid
Version: unspecified → 36 Branch

Comment 18

3 years ago
Dan, I do not see any recent crashes for you on crash-stats. Is your problem gone?  If so, how did  you solve it?
Flags: needinfo?(dhimes)
Keywords: crashreportid
Whiteboard: [closeme 2015-10-20]

Comment 19

3 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago3 years ago
Flags: needinfo?(dhimes)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2015-10-20]
(Reporter)

Comment 20

3 years ago
Wayne, I'm very sorry I missed seeing your question to me.  I have no further problems with this issue- seemed to be the incompatibility with the add-on checker.

I did have another crash- and made a quick note that mynoise.net wasn't working in Linux Firefox.  Should be an entirely different report though- I just appended a note about the website to a normal crash report.  (Just for completeness because I brought it up:  The site dev says it works for him in OSX.  Works in Windows.  Works on the linux box in Chrome.  Might be an ogg file thing.)

Comment 21

3 years ago
Thanks for the update
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.