Closed Bug 1148503 Opened 5 years ago Closed 5 years ago

TEST-UNEXPECTED-FAIL | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | xpcshell return code: 0

Categories

(Thunderbird :: General, defect)

x86_64
Windows 8.1
defect
Not set

Tracking

(firefox40 fixed)

RESOLVED FIXED
Thunderbird 40.0
Tracking Status
firefox40 --- fixed

People

(Reporter: rkent, Assigned: swu)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file, 2 obsolete files)

New telemetry test failures. Multiple failures:

6781 14:28:05 INFO - TypeError: Cc['@mozilla.org/pac-generator;1'] is undefined at /builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_pac_generator.js:16
6800 14:28:06 WARNING - TEST-UNEXPECTED-FAIL | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | xpcshell return code: 0
6872 14:28:06 WARNING - TEST-UNEXPECTED-FAIL | toolkit/components/telemetry/tests/unit/test_TelemetryPing.js | asyncSetup - [asyncSetup : 199] null == "1568524f-d938-b34a-aba2-9759e1d9993f"
6907 14:28:07 WARNING - TEST-UNEXPECTED-FAIL | toolkit/components/telemetry/tests/unit/test_TelemetrySendOldPings.js | xpcshell return code: 0
7045 14:28:07 WARNING - TEST-UNEXPECTED-FAIL | toolkit/components/telemetry/tests/unit/test_TelemetrySession.js | xpcshell return code: 0
7164 14:28:07 WARNING - TEST-UNEXPECTED-FAIL | toolkit/components/telemetry/tests/unit/test_TelemetrySession.js | asyncSetup - [asyncSetup : 550] null == "4b85fe7c-0265-bd40-a6d0-72d3df1d12c0"
7199 14:28:08 WARNING - TEST-UNEXPECTED-FAIL | toolkit/modules/tests/xpcshell/test_TelemetryTimestamps.js | xpcshell return code: 0
7352 14:28:08 ERROR - Return code: 1
The pac error is from bug 1115495. Ratty asked in bug 1115495 comment 59 to restrict the failing test to B2G (else we would have to ship unused files).
Blocks: 1115495
Keywords: regression
Enable PAC Generator test on B2G only.
Assignee: nobody → swu
Attachment #8585276 - Flags: review?(mcmanus)
Comment on attachment 8585276 [details] [diff] [review]
Patch: Test PAC Generator on B2G only.

After applied this patch, the test is neither run on b2g desktop nor b2g emulator in treeherder.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a6f217e9f776

So, cancel review for now.  Need to find a different way to solve this issue.
Attachment #8585276 - Flags: review?(mcmanus)
@ahal, I would like to limit the xpcshell test netwerk/test/unit/test_pac_generator.js to b2g only, but the b2g desktop doens't do xpcshell test at all in treeherder, and b2g emulator doesn't cover this test because of https://dxr.mozilla.org/mozilla-central/source/netwerk/test/unit/xpcshell.ini#4

Do you have any suggestions?
Flags: needinfo?(ahalberstadt)
So if you want to keep all the other tests disabled on B2G you could pull that test out of that manifest and into a new manifest. If you do that don't forget to add it here:
https://dxr.mozilla.org/mozilla-central/source/netwerk/test/moz.build#14

Alternatively you could remove the DEFAULT skip-if and add it to every individual test except for test_pac_generator.js.
Flags: needinfo?(ahalberstadt)
(In reply to Andrew Halberstadt [:ahal] from comment #24)
> So if you want to keep all the other tests disabled on B2G you could pull
> that test out of that manifest and into a new manifest. If you do that don't
> forget to add it here:
> https://dxr.mozilla.org/mozilla-central/source/netwerk/test/moz.build#14
> 
> Alternatively you could remove the DEFAULT skip-if and add it to every
> individual test except for test_pac_generator.js.

Thanks for your suggestions.
The patch separates b2g xpcshell test into a different manifest.

Note:
1. To make the test also available for B2G desktop, we use buildapp == 'b2g' instead of toolkit == 'gonk'.
2. Although only head_cache2.js in xpcshell_b2g.ini is needed for now, we add all head_* here just for consistency.

Treeherder resolve looks good:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a230e90e5cb8

Patrick, could you review it?
Attachment #8585276 - Attachment is obsolete: true
Attachment #8586035 - Flags: review?(mcmanus)
Comment on attachment 8586035 [details] [diff] [review]
Patch: Test PAC Generator on B2G only.

Review of attachment 8586035 [details] [diff] [review]:
-----------------------------------------------------------------

thanks!

::: netwerk/test/unit/xpcshell_b2g.ini
@@ +2,5 @@
> +head = head_channels.js head_cache.js head_cache2.js
> +tail =
> +skip-if = buildapp != 'b2g'
> +
> +[test_pac_generator.js]

a comment here that this is to accommodate non-mozilla central would be helpful.
Attachment #8586035 - Flags: review?(mcmanus) → review+
(In reply to Patrick McManus [:mcmanus] from comment #249)
> Comment on attachment 8586035 [details] [diff] [review]
> Patch: Test PAC Generator on B2G only.
> 
> Review of attachment 8586035 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> thanks!
> 
> ::: netwerk/test/unit/xpcshell_b2g.ini
> @@ +2,5 @@
> > +head = head_channels.js head_cache.js head_cache2.js
> > +tail =
> > +skip-if = buildapp != 'b2g'
> > +
> > +[test_pac_generator.js]
> 
> a comment here that this is to accommodate non-mozilla central would be
> helpful.

OK, thanks.
Added comment for the test case.
Attachment #8586035 - Attachment is obsolete: true
Attachment #8587080 - Flags: review+
In the patch, the b2g specific test case was moved into a xpcshell_b2g.ini, using |skip-if = buildapp != 'b2g'|, and changed xpcshell.ini to use |skip-if = buildapp == 'b2g'|.

With a second thought, I realized that for xpcshell.ini, it should be better to keep using |skip-if = toolkit == 'gonk'|, because we don't need to disabled those tests on b2g desktop.

In order not to block on this bug, I will filed a new bug for discussion.
Filed bug 1150318 for comment 253.
https://hg.mozilla.org/mozilla-central/rev/98c2ee502511
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 40.0
You need to log in before you can comment on or make changes to this bug.