[e10s] HMDInfoOculus shouldn't instantiate in the content process

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: jimm, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

4 years ago
Spun off from bug 1147830, we should add some XRE_GeckoProcessType() checks to the initialization of this vr code. It was trying to launch in the child.

I'm pretty sure the fix in bug 1147830 works around this, but we should add an explicit process check in here too.
I'm working on a refactor of this in bug 1148009, and we should do this after that.. but I want to fix VR stuff to work with e10s, because e10s is going to be the standard down the line.

I'm mostly worried about the latency issues with e10s, if we end up reading sensor data in the chrome process and have to send it down to content of our ipc.  Milliseconds matter here, but I don't know of any way to get around this for now.
Whiteboard: [gfx-noted]
(Reporter)

Updated

4 years ago
Flags: needinfo?(gwright)
Since bug 1149566 landed, this is no longer an issue for e10s as we can't have e10s and VR enabled at the same time. Removing tracking-e10s accordingly.
tracking-e10s: ? → ---
Flags: needinfo?(gwright)
(Reporter)

Comment 3

4 years ago
resolved dupe of bug 1149566? then?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

4 years ago
oops, well, I guess wfm works too. :)
Vlad talked of leaving this open to track a more long-term fix, but I think he's gone ahead and filed a new bug for that anyway. Worksforme seems good :)
You need to log in before you can comment on or make changes to this bug.