Dispatch touch events before composites

RESOLVED FIXED in Firefox 40, Firefox OS v2.2

Status

()

Core
Panning and Zooming
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mchang, Assigned: mchang)

Tracking

Trunk
mozilla40
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox38 wontfix, firefox39 wontfix, firefox40 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
Right now, we composite then dispatch touch events. We originally had to do this with silk because touch events were processed on the main thread and we didn't want to block composition on the main thread. Since bug 930939, we dispatch touch events on the compositor through straight through to the APZ. We can remove one frame of latency by dispatching touch events first, then composting with the updated touch input data.
(Assignee)

Comment 1

3 years ago
Created attachment 8584780 [details] [diff] [review]
Dispatch touch events before composites
Attachment #8584780 - Flags: review?(bugmail.mozilla)
(Assignee)

Updated

3 years ago
status-b2g-v2.2: --- → affected
Attachment #8584780 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/6312bb5f0108
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
(Assignee)

Comment 4

3 years ago
Created attachment 8585849 [details] [diff] [review]
Dispatch touch events before composites v2.2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Silk
User impact if declined: This patch is a performance improvement which reduces touch latency by 16 ms.
Testing completed: Manual, mochitest
Risk to taking this patch (and alternatives if risky): Low, we already dispatch touch events. Now we just do it before composites so touch events are rendered on the screen sooner, making it feel more responsive.
String or UUID changes made by this patch: None
Attachment #8585849 - Flags: review+
Attachment #8585849 - Flags: approval-mozilla-b2g37?
status-b2g-master: --- → fixed
Target Milestone: mozilla39 → mozilla40
Comment on attachment 8585849 [details] [diff] [review]
Dispatch touch events before composites v2.2

Approving given the low risk perf win.
Attachment #8585849 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/20b67213a047
status-b2g-v2.2: affected → fixed
status-firefox38: --- → wontfix
status-firefox39: --- → wontfix
You need to log in before you can comment on or make changes to this bug.