[Browser] 'No Internet Connection" Settings Share can be dismissed by tapping top-right

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: oliverthor, Assigned: albertopq)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8584781 [details]
logcat_20150327_1330.txt

Description:
When the user attempts to search the browser without an internet connection (or data), they will receive a prompt of '[Gear] No Internet Connection'. This prompt may be tapped to open a share activity of Settings that displays methods of attaining internet connections. User will observe a 'Done' hypertext in the top-right that may be used to dismiss the activity; however if they navigate through (1) Wi-Fi and then select (2) a network, they may observe on both of these screens that in tapping the top right (where no 'Done' text is present), they are still able to dismiss the share activity.

PreReq:
* No internet connection (Data + WiFi disabled)
Repro Steps:
1) Update a Flame to 20150327010205
2) Open the Browser app.
3) Tap the Search bar.
4) Observe '[Gear] No Internet Connection'
5) Tap prompt seen in [4] to open Settings/Wifi share activity.
6) Tap Wi-Fi -- opens screen that displays all available networks**
7) Tap a network to join -- opens screen that asks for password to join**
8) Tap the top right corner in the screen that displays after performing step [6] or [7]

Actual:
Settings/Wifi share activity will dismiss and return user to browser when no button was tapped.

Expected:
No effect occurs without tapping an observable prompt.

Environmental Variables:
--------------------------------------------------

Device: Flame 3.0
Build ID: 20150327010205
Gaia: 249b8c08c1d57961ef6c905f3498fa62b032bf24
Gecko: e046475a75cb
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
--------------------------------------------------

Device: Flame 2.2
BuildID: 20150327002500
Gaia: f9f62d7b69c9d46a28b5ca4f18993c90b5a2b26a
Gecko: 17079fdf6c6f
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------------------
Issue DOES NOT REPRO on 2.1 for flame devices; exhibits different behavior
Results: User may access the Settings from Browser, but not through a share activity

Device: Flame 2.1
BuildID: 20150327001204
Gaia: 6f39e4e876152de1dcdcc0e7656197f22f105e4b
Gecko: f4d7c0e7292e
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
--------------------------------------------------


Repro frequency: 5/5
See attached: 
video- https://youtu.be/ATsdnfRA2VE  
logcat
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing], [systemsfe]
NI on component owner for nomination decision.  I believe this is an issue with the settings share activity, moving to Settings Component.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Component: Gaia::Browser → Gaia::Settings
Flags: needinfo?(pbylenga) → needinfo?(gchang)
Hi Arthur,
This might need your help to dispatch.
Flags: needinfo?(gchang) → needinfo?(arthur.chen)

Comment 3

3 years ago
Triage: blocking.
Assignee: nobody → arthur.chen
blocking-b2g: --- → 2.2+
Whiteboard: [3.0-Daily-Testing], [systemsfe] → [3.0-Daily-Testing]
Duplicate of this bug: 1147792
This was regressed by bug 1093755. Tapping the top of the panel ends the activity, so it doesn't have to be in the wifi panel as described in the STR.

Alberto, could you help check the issue? Thanks.
Assignee: arthur.chen → nobody
Blocks: 1093755
Flags: needinfo?(arthur.chen) → needinfo?(apastor)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
(Assignee)

Comment 6

3 years ago
Sure, I'll take a look. Thanks!
Assignee: nobody → apastor
Flags: needinfo?(apastor)
(Assignee)

Comment 7

3 years ago
I have the impression, that this might be a dupe of bug 1149116, which landed recently. The problem was that the utility-tray-opening event was triggered when tapping on the top, so that was closing the activity. Could you please check again with latest master? Thanks!
Flags: needinfo?(onelson)
(Assignee)

Comment 8

3 years ago
Adding the qawanted keyword to re-check
Keywords: qawanted
QA Contact: ychung
This issue still reproduce on the latest Flame Master.

Result: The Wi-fi settings screen is dismissed by tapping on the upper right corner.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150401030647
Gaia: 4bb3a933bd805e8df1e11827cb247754c3565b0b
Gecko: da2f28836843
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: ychung
(Assignee)

Comment 10

3 years ago
That's weird. I can repro with the same exact STR that this bug is describing, when flashing something previous to [1]. After that commit, it doesn't repro anymore.

In theory, the Gaia hash that you pointed out includes that commit, so I'm not sure what's going on. Kevin, can you try to repro? Thanks!

[1] https://github.com/mozilla-b2g/gaia/commit/e1e36c3f9952ae124e7a3424a751bc39d5416e83
Flags: needinfo?(kgrandon)
I am unable to reproduce this using the STR or steps in the video on master.

Adding qawanted to see if we can get a new video of reproducing this issue on master if it still exists.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(kgrandon)
Keywords: qawanted
Resolution: --- → WORKSFORME
Issue DOES reproduce in latest Flame 3.0

Youtube link: http://youtu.be/BNaXeL2lC5c

Device: Flame 3.0
Build ID: 20150401010204
Gaia: 03164bd160809747e6a198e0dba1b7c3ee7789f5
Gecko: 18a8ea7c2c62
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
Keywords: qawanted
Status: RESOLVED → REOPENED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: WORKSFORME → ---
Issue does reproduce in latest Mozilla-Central build in Flame 3.0, but does so in a slightly different way.

Tapping top right corner no longer dismisses settings, but dragging down notification tray only slightly results in same issue. Since this is still the utility tray, this appears to be the same bug (especially given commit pointed to in comment 10.)

Youtube video of these steps: http://youtu.be/3isnoAdTX-Q

Device: Flame 3.0
Build ID: 20150401030647
Gaia: 4bb3a933bd805e8df1e11827cb247754c3565b0b
Gecko: da2f28836843
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(onelson) → needinfo?(ktucker)
Based on Comment 13, Kevin do you want this written up as a different issue? Tapping in the upper right corner no longer dismisses the page but slightly pulling down the utility tray/status bar does.
Flags: needinfo?(ktucker) → needinfo?(kgrandon)
(In reply to KTucker [:KTucker] from comment #14)
> Based on Comment 13, Kevin do you want this written up as a different issue?
> Tapping in the upper right corner no longer dismisses the page but slightly
> pulling down the utility tray/status bar does.

Yes, this bug is getting a bit confusing due to different issues. If you wouldn't mind creating a new issue for this I would appreciate it. Thanks!
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(kgrandon)
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

3 years ago
Logged bug 1150214 in response to comment#15:
[Browser] 'No Internet Connection' settings is dismissed upon revealing the Notification Tray
See Also: → bug 1150214
You need to log in before you can comment on or make changes to this bug.