Password manager fills inputs even if cancel is clicked

RESOLVED WORKSFORME

Status

SeaMonkey
Passwords & Permissions
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Yasuo Ohgaki, Assigned: Stephen P. Morse)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011211
BuildID:    2001121106

Reported as discussed with Steve Morse (morse@netscape.com) via e-mail.

Mozilla shows up dialog(I don't remeber exact message...)
Select user that filled this form"

Form is filled with *old* data no matter which button is clicked (OK or
Cancel) Inputs other than username and password are filled also.

After I delete the *.s file from the profile, Mozilla stopped doing that. (i.e.
Mozilla stopped displaying the dialog, since I didn't let mozilla remember
password) 

Reproducible: Always
Steps to Reproduce:
1. Enter form with user and password
2. Click submit button
3. Save password
4. Open form again
5. Click Cancel or Okfor password manager

Actual Results:  Older values are inserted to inputs

Expected Results:  Mozilla shouldn't insert older values if user click cancel

Since I'm using the profile from mozilla 0.9.4, mozilla may not do that with
fresh profile.... However, mozilla stopped inserting older form data if I delete
*.s file from the profile, at least for me.

I'll try to reproduce if you cannot reproduce this problem.
I can't duplicate this using 2001121208 linux. Canceling out rightly does nothing.

Reporter, can you try with a fresh profile?
(Reporter)

Comment 2

17 years ago
Ok I tried with fresh profile with the same build. Mozilla won't fill fileds
when cancel is clicked. However, there are issues regarding password manager.

1) When I have only 1 password saved for the page, mozilla won't ask and fills
old values automatically. If you take look at following URL, you'll see OS/PHP
Version/Summury, etc. These inputs are filled with *OLD* values.....
http://bugs.php.net/bug.php?id=10113&edit=1

2) When I edit & submit bug reports, Mozilla saves password everytime I edit &
submit(update) bug report, since values in bug report pages are different.

It would be better to ask user if user is willing to fill form for first
problem. It may be better to ask users if user is willing to save password for
second problem.
(Assignee)

Comment 3

17 years ago
You shouldn't be using password manager to save values in a bug-submission form.
(Reporter)

Comment 4

17 years ago
I shouldn't use password maneger for bug report.
I figured out that now :)

But I would like to mozilla to ask if it is ok to fill password when there is 1
password is saved. I also would like to be asked if mozilla is going to save
another password for the same URL. (Well query string differs, but it seems
mozilla checks URI without query string)

I don't mind at all, if you make this report INVALID or WONTFIX :)
(Assignee)

Comment 5

17 years ago
Marking as wfm per Aillon's statement in comment #1, and per reporter's 
statement in comment #3 that it is working with a fresh profile.

If there are suggestions for enhancements as indicated in reporter's comment #3, 
please file them in a separate bug report. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.