[Contacts] App header is briefly displayed as 'Select Contact' after doing certain actions (see comment 10 for updated behavior)

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: piwei, Assigned: ferjm)

Tracking

({regression, verifyme})

unspecified
2.2 S11 (1may)
ARM
Gonk (Firefox OS)
regression, verifyme
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 affected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8584866 [details]
logcat of issue

Description:
The 'Contacts' header permanently becomes 'Select Contact' after selecting to share an image via Messages and picking up a contact.

Prerequisites:
- Have a contact with name and phone number
- Have a picture in the Gallery

STR:
1) Go to Gallery > tap to view any picture > share via Messages
2) Wait until image is done resizing, then tap on '+' icon to add a contact
3) Tap on the contact created at prerequisites
4) Tap on X to exit out and discard the message
5) Open Contacts app

Expected: Contact app shows header as 'Contacts'

Actual: Contacts app shows header as 'Select contact'. This effect is permanent until all contacts are deleted in the app and then cold launch contacts will fix it. Rebooting the device won't fix the issue.

Video of issue:
https://www.youtube.com/watch?v=i5yTMsdoHoc

Also attaching a logcat.

Repro frequency: 5/6

Device: Flame 3.0 Master (KK, full flash, 319MB mem)
BuildID: 20150327010205
Gaia: 249b8c08c1d57961ef6c905f3498fa62b032bf24
Gecko: e046475a75cb
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
(Reporter)

Comment 1

3 years ago
This issue does NOT occur on Flame 2.2. Repro frequency: 0/5.

Device: Flame 2.2
BuildID: 20150327002500
Gaia: f9f62d7b69c9d46a28b5ca4f18993c90b5a2b26a
Gecko: 17079fdf6c6f
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing]
[Blocking Requested - why for this release]:

This is a bad regression from 2.2 so nominating this 3.0?
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: ychung
(Reporter)

Updated

3 years ago
QA Contact: ychung → pcheng
(Reporter)

Comment 3

3 years ago
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20150320111335
Gaia: 66558ce7f36809a20d1c721fd4d457913b09c5c7
Gecko: 832cc58f3e44
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20150320112039
Gaia: 9c4521cb9108c5169965f15d81900bf40e814154
Gecko: 9f06ffa1eb36
Version: 39.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: 66558ce7f36809a20d1c721fd4d457913b09c5c7
Gecko: 9f06ffa1eb36

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: 9c4521cb9108c5169965f15d81900bf40e814154
Gecko: 832cc58f3e44

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/66558ce7f36809a20d1c721fd4d457913b09c5c7...9c4521cb9108c5169965f15d81900bf40e814154

Bug 1144433 is the only bug in the pushlog. I noticed that it was also uplifted to 2.2, so I double checked this bug on latest 2.2 and couldn't repro the bug. I then reverted the patch on master and verified that after reverting, the bug reproduces 0 out of 10 attempts.

Perhaps something else on master + the patch for bug 1144433 caused this issue to occur.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Fernando, can you take a look at this please? This might have been caused by the landing for bug 1144433. This issue does not occur on 2.2 but it happens on master for some reason.
Blocks: 1144433
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(ferjmoreno)
(Assignee)

Updated

3 years ago
Assignee: nobody → ferjmoreno
Flags: needinfo?(ferjmoreno)
(Assignee)

Comment 5

3 years ago
This is caused by bug 1144838. We don't have localization of the header, so we can't update the cached content.
(Assignee)

Updated

3 years ago
Depends on: 1144838
(Assignee)

Comment 6

3 years ago
Oh, and we are not even updating in the case of a locale change, only in the case of a direction change. We also need to fix that.
(Assignee)

Updated

3 years ago
Depends on: 1149662
(Assignee)

Comment 7

3 years ago
I filed bug 1149662 for the cache update that I mentioned in comment 6, but we still need bug 1144838 fixed to fix this one.
triage: regression, breaking function
blocking-b2g: 3.0? → 3.0+
(Assignee)

Comment 9

3 years ago
Even if bug 1144838 should fix this eventually, bug 1151594 will also do the work, so I am closing this one as a dup.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151594
(Reporter)

Comment 10

3 years ago
Bug 1144838 is verified fixed but did not completely fix this bug. With the same STR at comment 0, user now sees app header temporarily becomes 'Select Contact', instead of seeing it permanently like what was described on comment 0.

Also setting v2.2 as affected because the patch revealing this bug has been uplifted and I can reproduce the issue on v2.2.
Status: RESOLVED → REOPENED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: unaffected → affected
Flags: needinfo?(ktucker)
Resolution: DUPLICATE → ---
Summary: [Contacts] App header permanently becomes 'Select Contact' after doing certain actions → [Contacts] App header is briefly displayed as 'Select Contact' after doing certain actions
(Reporter)

Comment 11

3 years ago
I meant to say bug 1151594 is verified fixed.
(Reporter)

Updated

3 years ago
Summary: [Contacts] App header is briefly displayed as 'Select Contact' after doing certain actions → [Contacts] App header is briefly displayed as 'Select Contact' after doing certain actions (see comment 10 for updated behavior)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Created attachment 8593233 [details] [review]
[gaia] ferjm:bug1148654.contacts.header.cache.followup > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Attachment #8593233 - Flags: review?(francisco)
Comment on attachment 8593233 [details] [review]
[gaia] ferjm:bug1148654.contacts.header.cache.followup > mozilla-b2g:master

Easy one :), thanks Fernando
Attachment #8593233 - Flags: review?(francisco) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29540

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Going to try to re-land this.
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
http://docs.taskcluster.net/tools/task-graph-inspector/#FPWxIPjFQwOftNqoRDQCXw

The pull request failed to pass integration tests. It could not be landed, please try again.
(Assignee)

Comment 17

3 years ago
https://github.com/mozilla-b2g/gaia/commit/aa4faf9a5b5cf48bc53d81931ead6038cf451897
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S11 (1may)
(Reporter)

Comment 18

3 years ago
Since 2.2 is later marked as affected, should we reconsider nominating it as 2.2 blocker?

----

This issue is verified fixed on Flame 3.0. Following STR, app header displays the expected name. Since 3.0 currently suffers from bad memory managing where it can hardly have two apps opened at the same time, I also tried to reproduce this issue in 512MB memory and couldn't repro. Bug repro rate: 0 out of 10 attempts.

Device: Flame 3.0
BuildID: 20150506010204
Gaia: 3e6fd1e0a478af2c95d09ce95c2c6de2de2fec14
Gecko: ba44099cbd07
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Waiting for triage to decide whether v2.2 should be blocked, if so we should add verifyme keyword.
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Adding verifyme to check 2.2 once it has been uplifted.
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
status-b2g-v2.5: --- → verified
status-b2g-v2.5: verified → ---
You need to log in before you can comment on or make changes to this bug.