Browser Content Toolbox fails to populate

RESOLVED FIXED in Firefox 39

Status

()

Firefox
Developer Tools: Debugger
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jimm, Assigned: jlongster)

Tracking

({regression})

Trunk
Firefox 40
regression
Points:
---

Firefox Tracking Flags

(e10s?, firefox39+ fixed, firefox40 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR: open a browser, browse to a site to launch the content process, open dev tool Browser Content Toolbox.

result: no information is displayed in the ui

I did a rough spot check, this regressed between the 21st and the 26th.
(Reporter)

Comment 1

3 years ago
onPacket threw an exception:

Error: Server did not specify an actor, dropping packet: {"error":"unknownError","message":"error occurred while processing 'attach:TypeError:this.sourcesis undefined\nStack: ThreadActor.prototype.onAttach@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/script.js:663:5\nDSC_onPacket@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/main.js:1459:15\nChildDebuggerTransport.prototype.receiveMessage@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/transport/transport.js:734:5\nLine: 663, column: 4"}

Stack:
DebuggerClient.prototype.onPacket@resource://gre/modules/devtools/dbg-client.jsm:941:1
LocalDebuggerTransport.prototype.send/<@resource://gre/modules/devtools/dbg-client.jsm -> resource://gre/modules/devtools/transport/transport.js:561:11
makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:82:14
makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:82:14
Line: 941, column: 0
(Reporter)

Comment 3

3 years ago
inbound:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f0a4844f0ccd&tochange=43ef69c1f6b5

not seeing much here, I'll try some local backouts.
(Reporter)

Comment 4

3 years ago
Last good revision: 840cfd5bc971 (2015-03-24)
First bad revision: db0409de517a (2015-03-25)

I'm not having any luck finding the regression push after backing out what appeared to be most likely candidates.

I can confirm though that an hg update 840cfd5bc971 fixes the problem.
The stack points to the debugger, so moving there. James, could this be related to the patch that moves source actors to another file?
Component: Developer Tools → Developer Tools: Debugger
Flags: needinfo?(jlong)
Duplicate of this bug: 1149173
Also happens on mac.
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Comment 8

3 years ago
bug 1137384 did break this. I don't know why we have instances of things that look like tab actors but don't inherit from TabActor. Right now there's a loose protocol that the object needs to implement and now creating a TabSources object is part of that. It would be nice to enforce this protocol instead of just using duck typing.

I can make a patch
Flags: needinfo?(jlong)
(Assignee)

Comment 9

3 years ago
Created attachment 8585559 [details] [diff] [review]
1148753.patch

This should fix it. jryans let me know if someone other than you should review
Attachment #8585559 - Flags: review?(jryans)
Comment on attachment 8585559 [details] [diff] [review]
1148753.patch

Looks good!
Attachment #8585559 - Flags: review?(jryans) → review+
(Assignee)

Comment 11

3 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=061a7c89f8d0

We should try to land this today because an uplift is happening tonight.
(In reply to James Long (:jlongster) from comment #11)
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=061a7c89f8d0
> 
> We should try to land this today because an uplift is happening tonight.

I think this has missed the boat for the merge (m-c is already approval only).  But it will be an obvious candidate for aurora uplift.
[Tracking Requested - why for this release]: Make sure we don't forget to uplift.
status-firefox39: --- → affected
tracking-firefox39: --- → ?
(Assignee)

Comment 14

3 years ago
Sounds good.
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/43729f333234
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/43729f333234
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox40: --- → fixed
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 40
tracking-firefox39: ? → +
James, is this ready for an uplift request?
Assignee: nobody → jlong
Flags: needinfo?(jlong)
(Assignee)

Comment 18

3 years ago
Comment on attachment 8585559 [details] [diff] [review]
1148753.patch

Approval Request Comment
[Feature/regressing bug #]: bug 1137384
[User impact if declined]: browser content toolbox is broken
[Describe test coverage new/current, TreeHerder]: I don't think we run tests against the browser content toolbix, but any tests on it should have made this known
[Risks and why]: very little risk, only touches a devtool
[String/UUID change made/needed]:
Flags: needinfo?(jlong)
Attachment #8585559 - Flags: approval-mozilla-aurora?
Comment on attachment 8585559 [details] [diff] [review]
1148753.patch

Approved for uplift to 39; low risk fix to a regression.
Attachment #8585559 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: regression
You need to log in before you can comment on or make changes to this bug.