Large download ends prematurely

VERIFIED WORKSFORME

Status

Core Graveyard
File Handling
--
major
VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: Devoti Paolo, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupeme, URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.6+) Gecko/20011128
BuildID:    2001112803

When downloading the provided url it ends after something more than 100 megs. 3
attempts same result 
download was at about 50kB/s and worked smootly with ns4.7

Reproducible: Always
Steps to Reproduce:
1.paste in urlbar the provided url to start the download
2.choose save as
3.wait

Actual Results:  download stopped much before the real end of transfer

Expected Results:  file downloaded
How many disk space do you have free on drive c: ?
(Reporter)

Comment 2

17 years ago
about 4 giga

Comment 3

17 years ago
Reporter: I suggest that you change the severity level to "critical",
since data loss is involved.

see also Bug 128907

Comment 4

17 years ago
See also bug 121532
*** Bug 128907 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Is this still a problem in a current build?

pi
(Reporter)

Comment 7

16 years ago
still a problem, win98 2002061408 internet access using a zyxel 642r adsl router
this time average speed was 24.5kbs and it stopped at 72MB
Severity: normal → critical
Severity: critical → major

Comment 8

16 years ago
old enough that it should be a known issue in the right component.
Assignee: neeti → law
Component: Networking → File Handling
QA Contact: benc → sairuh
Whiteboard: dupeme

Comment 9

16 years ago
I could not try the given URL, it requires a login. Do you have this problem
only there (and still in 1.1b or later) or also on other sites?

pi

Comment 10

16 years ago
I've signed up and tried to download the file with the linux 2002080614 build.
It's now at 230 MB and still happily downloading at 192 KB/s. Probably the
server has a timeout on how long a connection is kept open. You can try hitting
the pause/resume button a few times during the download, everytime you hit it, a
new http-connection gets established. That'll probably resolve the problem. Or
use a download manager.

Marking WorksForMe as I don't think it's a mozilla problem. If you come across
this more often, please REOPEN.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 11

16 years ago
> Probably the server has a timeout on 
> how long a connection is kept open

False. I've downloaded those files from Oracle site with 
a single ISDN connection, and it was successful
(after so many hours :( )

btw, maybe this bug is something related to bug 69938;
reporter, can you take a look at that bug and verify
the location of your /temp (or /tmp) directory?

Comment 12

16 years ago
Reporter: I think what corradobc wants to ask you is whether you have enough
disk space in the temporary directory mozilla uses to store the partially
downloaded file.

Is it possible that your zyxel router "looses" the route from the internet to
your local computer (which has only a local ip address) after some time? Or does
your ISP sometimes change your IP address (some do this every 24h), so this
could just have been bad luck?
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.