SWF #626 is very slow and has confetti animation bunched up on the left edge: "AVM1 error: TypeError: q is undefined"

RESOLVED DUPLICATE of bug 1151971

Status

defect
RESOLVED DUPLICATE of bug 1151971
4 years ago
3 years ago

People

(Reporter: cpeterson, Assigned: yury)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
http://swf.codeazur.com.br/#bc088d218e45925b19861841c95a0ae70cfe4b87b4ac79274f91e99aeda890ae

"AVM1 warning: cannot get member 'func' on undefined object" shumway.player.js:69889:12
"AVM1 warning: method 'apply' can't be called on undefined object" shumway.player.js:69889:12
"AVM1 warning: cannot get member 'target' on undefined object" shumway.player.js:69889:12
(Reporter)

Comment 1

4 years ago
Still broken in Shumway 0.11.7 redux. This bug might be related to confetti bug 1151971.
Summary: SWF #626 has animated green rectangle in upper left corner: "AVM1 warning: method 'apply' can't be called on undefined object" → SWF #626 has white rectangle in upper left corner and is missing confetti animation: "AVM1 warning: method 'apply' can't be called on undefined object"
The slowness is probably the same as with other particle animation things and filter-related. The AVM1 error is new to me and shouldn't happen, though.
Assignee: nobody → ydelendik
Blocks: shumway-m4
Summary: SWF #626 has white rectangle in upper left corner and is missing confetti animation: "AVM1 warning: method 'apply' can't be called on undefined object" → SWF #626 is very slow and has confetti animation bunched up on the left edge: "AVM1 error: TypeError: q is undefined"
(Reporter)

Comment 3

4 years ago
We're tracking similar particle performance issues in other bugs. Let's wait to see if this bug goes away.
Blocks: shumway-1.0
No longer blocks: shumway-m4
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151971
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.