Closed Bug 1148857 Opened 7 years ago Closed 7 years ago

HTTP 401 auth dialog doesn't pop up any more

Categories

(Firefox for Android Graveyard :: General, defect)

All
Android
defect
Not set
normal

Tracking

(firefox38 unaffected, firefox39+ verified, firefox40 verified, fennec39+)

VERIFIED FIXED
Firefox 40
Tracking Status
firefox38 --- unaffected
firefox39 + verified
firefox40 --- verified
fennec 39+ ---

People

(Reporter: kats, Assigned: kats)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

STR:
Go to a page with HTTP auth, e.g. https://staktrace.com/apps/bugmash/dashboard.php

ER:
Popup dialog asking for username/password

AR:
No dialog, goes straight to 401 error page from server.

This is a recent regression on nightly (maybe last couple of days).
Flags: needinfo?(flaviu.cos)
Inbound regression range:

Last good revision: aef75ff8a911
First bad revision: 44e454b5e93b
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=aef75ff8a911&tochange=44e454b5e93b
Flags: needinfo?(flaviu.cos)
Also in logcat I see this:

W/GeckoConsole(20809): [JavaScript Error: "_doAsyncPrompt:run: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/PromptService.js :: pu_getLocaleString :: line 557"  data: no]
W/GeckoConsole(20809): " {file: "jar:jar:file:///data/app/org.mozilla.fennec-1.apk!/assets/omni.ja!/components/PromptService.js" line: 482}]

so I'm gonna guess it's a regression from https://hg.mozilla.org/integration/fx-team/rev/ebf592c2fa4c
Blocks: 1088220
Flags: needinfo?(liuche)
Attached patch Patch (obsolete) — Splinter Review
This fixes it for me on a local build. The string is needed at http://mxr.mozilla.org/mozilla-central/source/mobile/android/components/PromptService.js?rev=687318d464a5#621
Assignee: nobody → bugmail.mozilla
Flags: needinfo?(liuche)
Attachment #8585429 - Flags: review?(liuche)
That works too.
Attachment #8585505 - Flags: review?(liuche)
Comment on attachment 8585505 [details] [diff] [review]
Alternate patch suggested by mfinkle

Review of attachment 8585505 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch, sorry about that!
Attachment #8585505 - Flags: review?(liuche) → review+
Comment on attachment 8585429 [details] [diff] [review]
Patch

No worries, thanks for the quick review!

https://hg.mozilla.org/integration/fx-team/rev/467d7e5ce428
Attachment #8585429 - Attachment is obsolete: true
Attachment #8585429 - Flags: review?(liuche)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
[Tracking Requested - why for this release]: Regression, would be great to get uplifted to 39 before Thursday to ship with Aurora enabling on Friday.
Comment on attachment 8585505 [details] [diff] [review]
Alternate patch suggested by mfinkle

Approval Request Comment
[Feature/regressing bug #]: bug 1088220
[User impact if declined]: password dialogs for 401 response codes dont appear
[Describe test coverage new/current, TreeHerder]: locally
[Risks and why]: low risk; breakage from a recent change pre-merge
[String/UUID change made/needed]: none
Attachment #8585505 - Flags: approval-mozilla-aurora?
Verified as fixed in build 40.0a1 (2015-03-31);
Device: Motorola Razr (Android 4.1.2).
Comment on attachment 8585505 [details] [diff] [review]
Alternate patch suggested by mfinkle

Taking this for 39 since it sounds low risk.
Attachment #8585505 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on Firefox 39.0a2 (2015-04-02)
Status: RESOLVED → VERIFIED
tracking-fennec: ? → 39+
Margaret noticed I marked 38 affected and the regressing bug is new in 39. Was fairly sure in triage that I just miss-clicked affected. Double checked just now and I am able to log in via http auth (intranet.mozilla.org) on Firefox 38 so setting unaffected.
Based on comment 13 I will remove the qe-verify, thanks.
Flags: qe-verify+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.