about:blank is always loaded on startup: we're ignoring "browser.startup.homepage" and "browser.startup.page" prefs

VERIFIED FIXED in M9

Status

defect
P1
normal
VERIFIED FIXED
20 years ago
15 years ago

People

(Reporter: sspitzer, Assigned: davidm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

aug 9, 10 am build:

./apprunner loads up about:blank, even though my prefs tell it to load
http://my.yahoo.com

What may be related:

from my console:

Doing Startup...
Creating browser app core
BrowserAppCore has been created.
Adding app core to AppCoreManager in the base initialization.
Setting content window
browser.startup.page = 1
startpage = http://my.yahoo.com
failed to set the page title.
Document about:blank loaded successfully

I was getting this on startup:

JavaScript error: uncaught exception: Component returned failure code:
0x8000ffff [nsIGlobalHistory.SetPageTitle, {file:
file:////builds/seth/MOZILLA/07.28.1999/19.52/mozilla/dist/bin/chrome/navigator/content/default/navigator.xul,
line: 37}]

I just checked in some try / catch code to catch this exception, so you won't
see it anymore.

brade brings up a good point, that may be related:
editor doesn't finish loading either (on Mac) until you click.

pink and brade are seeing this on mac, so marking all.
Assignee

Updated

20 years ago
Assignee: don → davidm
Assignee

Comment 1

20 years ago
Okay the problem is in nsBrowserAppCore::GetURLForIndex. the call to mSHistory->
GetURLForIndex(aIndex, aURL); returns an error which we then throw away. If you
return the error code life seems a lot better. The editor is still broken
Assignee

Updated

20 years ago
Status: NEW → ASSIGNED
Assignee

Comment 2

20 years ago
I think the editor is unrelated but don't hold me to it. The editor appears to
load the content but doesn't draw it while the browser never loads the content.
You might want to switch from using XUL callbacks ( which are supposed to be
going away) and see if moving that code to the onload handler makes any
difference. As it appears to work on linux I have a feeling the problem is along
the lines of update event either be dropped or not generated.

Comment 3

20 years ago
okay, so it sounds like the problem is known. who is on the hook to fix this? i'm
desperate to get the tree open today. should i be cc'ing another engineer?

Updated

20 years ago
Priority: P3 → P1
Target Milestone: M9
Assignee

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Assignee

Comment 4

20 years ago
Fix checked in.

Updated

20 years ago
QA Contact: leger → sujay

Comment 5

20 years ago
sujay, paulmac out today...can you very ok with all platforms today please?

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 6

20 years ago
verified in 8/12 build.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.