Inline Options: The "hidden" attribute does not work

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: Eduard Braun, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8585226 [details]
Minimal sample showing the issue

As the sample add-on shows, setting the "hidden" attribute on a setting does not work (or rather it works, as I checked with DOM Inspector, but does not have any visual influence).

The problem is that the following CSS rule in minimal-xul.css [1] 
  [hidden="true"] {
    display: none;
  }
gets overwritten by the following CSS rule in extensions.css [2]
  setting[type="bool"] {
    display: -moz-grid-line;
  }


Note that this example is only for <settings> with type="bool"
However all others <setting> types are also affected!


[1] http://lxr.mozilla.org/mozilla-central/source/toolkit/content/minimal-xul.css#42
[2] http://lxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/content/extensions.css#67

Comment 1

3 months ago
As of bug 1414406, inline settings are no longer supported.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.