Link to Bugzilla isn't easily findable on mozilla.org

RESOLVED WONTFIX

Status

www.mozilla.org
General
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: sstewartgallus00, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150323120601

Steps to reproduce:

I can't find a link to the Bugzilla bug report page from the mozilla.org site. I had to use a search engine to search for it to find it. It should be really, really, really easy to report a bug.
I understand the site navigation of mozilla.org is not user-friendly (it will to be improved sometime soon) but you can still find feedback links on the Contact page: https://www.mozilla.org/en-US/contact/

And I personally think that Bugzilla's less visibility is intentional because this system is mainly for developers and testers. End users are encouraged to use the feedback form. Making reporting a bug "really, really, really easy" leads to tremendous useless bug reports, which makes it very difficult to find real, important issues.

Filing a product bug is rather very hard, requiring tests with the latest Nightly builds as the document describes: https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

3 years ago
Summary: Bugzilla page isn't easily findable → Link to Bugzilla isn't easily findable on mozilla.org
I agree with Kohei that we should be pointing end users with Firefox issues to SUMO and not Bugzilla.

We have a "contribute to this site" link in the footer that points to https://wiki.mozilla.org/Webdev/GetInvolved/mozilla.org which has a prominent link to bugzilla and while that is focused on contributors it hopefully helps users, devs and testers with legitimate bugs find bugzilla more easily.
+1 to the comments from Mike and Kohei explaining why a link to Bugzilla isn't prominent on www.mozilla.org.

I'm going to close this one.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.