Glitches when AudioNode connected to playbackRate param of BufferSourceNode

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: sebpiq, Assigned: padenot)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150321175551

Steps to reproduce:

Tried to connect an AudioNode to the playbackRate AudioParam of a BufferSourceNode.

A jsfiddle can show the issue : http://jsfiddle.net/gh144L2u/


Actual results:

The playbackRate is modulated by the AudioNode as expected, however, it creates loud glitches in the output.
(Assignee)

Updated

4 years ago
Assignee: nobody → padenot
Component: Untriaged → Web Audio
Product: Firefox → Core
Version: 36 Branch → Trunk
Works for me (no glitching) in Fx 43 (and sounds identical to Chrome).  If this is still happening, please re-open or comment here.  Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.