Closed Bug 1149065 Opened 5 years ago Closed 5 years ago

NetBSD: Compilation error due to missing ProfilerBacktrace.h

Categories

(Firefox :: Untriaged, defect)

x86_64
NetBSD
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1145988

People

(Reporter: wiz, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; NetBSD amd64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150327043829

Steps to reproduce:

A couple of days ago, the trunk builds on NetBSD stopped working with:
mozilla/layout/base/RestyleTracker.h:19:31: fatal error: ProfilerBacktrace.h: No such file or directory

I guess this started with 234721:703caa5d845f

# HG changeset patch
# User chiajung hung <chung@mozilla.com>
# Date 1426727940 -3600
#      Thu Mar 19 02:19:00 2015 +0100
# Node ID 703caa5d845f02d37f98f099540a00d4f2353af6
# Parent  8cd33e72eb47595535b3a747875f81c575baf287
Bug 1129249 - Add a "restyle" feature to profiler and split the style label in Cleopatra based on the restyleSour

which added the include to the file.


Actual results:

See above


Expected results:

@landry told me that similar errors happen when someone relies on the fact that the sps profiler is enabled on all "supported" platforms and forgets that some platforms don't have it.
Blocks: 1129249
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145988
You need to log in before you can comment on or make changes to this bug.